summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-21 05:52:38 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-21 05:52:38 +0000
commit17880eac0f753654888deaaa958b1b130de152d3 (patch)
treed395477da44cc9db646a5a465c7e7d872638f01f /app-emacs
parentfix addpredict usage in pitivi (diff)
downloadgentoo-2-17880eac0f753654888deaaa958b1b130de152d3.tar.gz
gentoo-2-17880eac0f753654888deaaa958b1b130de152d3.tar.bz2
gentoo-2-17880eac0f753654888deaaa958b1b130de152d3.zip
Autoload instead of require. Make use of elisp.eclass defaults.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/php-mode/ChangeLog6
-rw-r--r--app-emacs/php-mode/files/51php-mode-gentoo.el8
-rw-r--r--app-emacs/php-mode/php-mode-1.2.0.ebuild19
3 files changed, 17 insertions, 16 deletions
diff --git a/app-emacs/php-mode/ChangeLog b/app-emacs/php-mode/ChangeLog
index 519dc398848e..ae7d8b3f735a 100644
--- a/app-emacs/php-mode/ChangeLog
+++ b/app-emacs/php-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/php-mode
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/php-mode/ChangeLog,v 1.16 2007/03/08 07:56:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/php-mode/ChangeLog,v 1.17 2007/04/21 05:52:38 ulm Exp $
+
+ 21 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +files/51php-mode-gentoo.el,
+ php-mode-1.2.0.ebuild:
+ Autoload instead of require. Make use of elisp.eclass defaults.
08 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/50php-mode-gentoo.el:
diff --git a/app-emacs/php-mode/files/51php-mode-gentoo.el b/app-emacs/php-mode/files/51php-mode-gentoo.el
new file mode 100644
index 000000000000..5db8dc5a055c
--- /dev/null
+++ b/app-emacs/php-mode/files/51php-mode-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; php-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'php-mode "php-mode" "Major mode for editing PHP code." t)
+(add-to-list 'auto-mode-alist '("\\.php[s34]?\\'" . php-mode))
+(add-to-list 'auto-mode-alist '("\\.phtml\\'" . php-mode))
+(add-to-list 'auto-mode-alist '("\\.inc\\'" . php-mode))
diff --git a/app-emacs/php-mode/php-mode-1.2.0.ebuild b/app-emacs/php-mode/php-mode-1.2.0.ebuild
index ff49f51faf83..d65272547bf9 100644
--- a/app-emacs/php-mode/php-mode-1.2.0.ebuild
+++ b/app-emacs/php-mode/php-mode-1.2.0.ebuild
@@ -1,29 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/php-mode/php-mode-1.2.0.ebuild,v 1.1 2007/02/09 08:32:37 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/php-mode/php-mode-1.2.0.ebuild,v 1.2 2007/04/21 05:52:38 ulm Exp $
inherit elisp
-IUSE=""
-
DESCRIPTION="GNU Emacs major mode for editing PHP code"
HOMEPAGE="http://php-mode.sourceforge.net"
SRC_URI="mirror://sourceforge/php-mode/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-DEPEND=""
+IUSE=""
S="${WORKDIR}"
-SITEFILE=50php-mode-gentoo.el
-
-src_compile() {
- emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
-}
-
-src_install() {
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-}
+SITEFILE=51${PN}-gentoo.el