summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 11:20:41 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 11:20:41 +0000
commit131d2a9f01b413aeaac6a0465dfe833eb9ac2511 (patch)
tree743c2a582bdc1438ce5c4fd4124915ac4558c82a /app-emacs
parentFixing Changelog entries, due to unset ECHANGELOG_USER variable (diff)
downloadgentoo-2-131d2a9f01b413aeaac6a0465dfe833eb9ac2511.tar.gz
gentoo-2-131d2a9f01b413aeaac6a0465dfe833eb9ac2511.tar.bz2
gentoo-2-131d2a9f01b413aeaac6a0465dfe833eb9ac2511.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ess/ChangeLog7
-rw-r--r--app-emacs/ess/ess-5.7.1-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emacs/ess/ChangeLog b/app-emacs/ess/ChangeLog
index 63bf556968a3..f2946b534843 100644
--- a/app-emacs/ess/ChangeLog
+++ b/app-emacs/ess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ess
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.58 2010/01/11 18:04:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.59 2010/01/31 11:20:41 ulm Exp $
+
+*ess-5.7.1-r1 (31 Jan 2010)
+
+ 31 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +ess-5.7.1-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
11 Jan 2010; Raúl Porcel <armin76@gentoo.org> ess-5.7.1.ebuild:
alpha/sparc stable wrt #299973
diff --git a/app-emacs/ess/ess-5.7.1-r1.ebuild b/app-emacs/ess/ess-5.7.1-r1.ebuild
new file mode 100644
index 000000000000..2cb0e8139849
--- /dev/null
+++ b/app-emacs/ess/ess-5.7.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.7.1-r1.ebuild,v 1.1 2010/01/31 11:20:41 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # Most documentation is installed by the package's build system
+ rm -f "${ED}${SITELISP}/ess/lisp/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf} || die "dodoc failed"
+ newdoc lisp/ChangeLog ChangeLog-lisp || die "newdoc failed"
+ prepalldocs
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please see /usr/share/doc/${PF} for the complete documentation."
+ elog "Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+}