summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-11-18 02:55:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-11-18 02:55:12 +0000
commit0140045aa450be9294762b76db166cf8f8a1ccc4 (patch)
tree9b1a4fb85a679f830fb505fd50d7ee4c506b88cc /app-emacs
parentwe dont inherit ../base (diff)
downloadgentoo-2-0140045aa450be9294762b76db166cf8f8a1ccc4.tar.gz
gentoo-2-0140045aa450be9294762b76db166cf8f8a1ccc4.tar.bz2
gentoo-2-0140045aa450be9294762b76db166cf8f8a1ccc4.zip
*** empty log message ***
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/initsplit/ChangeLog10
-rw-r--r--app-emacs/initsplit/Manifest4
-rw-r--r--app-emacs/initsplit/files/50initsplit-gentoo.el14
-rw-r--r--app-emacs/initsplit/files/digest-initsplit-1.61
-rw-r--r--app-emacs/initsplit/initsplit-1.6.ebuild25
-rw-r--r--app-emacs/initsplit/metadata.xml5
6 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/initsplit/ChangeLog b/app-emacs/initsplit/ChangeLog
new file mode 100644
index 000000000000..99a382fa9a87
--- /dev/null
+++ b/app-emacs/initsplit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/initsplit
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/initsplit/ChangeLog,v 1.1 2004/11/18 02:55:12 mkennedy Exp $
+
+*initsplit-1.6 (17 Nov 2004)
+
+ 17 Nov 2004; Matthew Kenendy <mkennedy@gentoo.org> +metadata.xml,
+ +files/50initsplit-gentoo.el, +initsplit-1.6.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/initsplit/Manifest b/app-emacs/initsplit/Manifest
new file mode 100644
index 000000000000..a6048f797738
--- /dev/null
+++ b/app-emacs/initsplit/Manifest
@@ -0,0 +1,4 @@
+MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
+MD5 1f0af3717285a42fbf0d14e8633cb887 initsplit-1.6.ebuild 620
+MD5 f3f73a0c3447dd52cd8fa70db47c8465 files/digest-initsplit-1.6 63
+MD5 e7bb76099eabbf75a3fcc402468aca4e files/50initsplit-gentoo.el 395
diff --git a/app-emacs/initsplit/files/50initsplit-gentoo.el b/app-emacs/initsplit/files/50initsplit-gentoo.el
new file mode 100644
index 000000000000..656d0dc49f02
--- /dev/null
+++ b/app-emacs/initsplit/files/50initsplit-gentoo.el
@@ -0,0 +1,14 @@
+
+;;; initsplit site-lisp configuration
+
+(require 'initsplit)
+
+;; Avoid clobbering the kill ring (see
+;; http://www.emacswiki.org/cgi-bin/wiki?InitSplit)
+
+(defadvice initsplit-split-customizations (around do-the-initsplit act)
+ "Don't clobber the `kill-ring' when writing customizations."
+ (let ((orig-kill-ring kill-ring))
+ (unwind-protect
+ ad-do-it
+ (setq kill-ring orig-kill-ring)))) \ No newline at end of file
diff --git a/app-emacs/initsplit/files/digest-initsplit-1.6 b/app-emacs/initsplit/files/digest-initsplit-1.6
new file mode 100644
index 000000000000..723c4cc3e71d
--- /dev/null
+++ b/app-emacs/initsplit/files/digest-initsplit-1.6
@@ -0,0 +1 @@
+MD5 a2d2a2600630367c65f8bd69c18fb0c1 initsplit-1.6.tar.gz 2454
diff --git a/app-emacs/initsplit/initsplit-1.6.ebuild b/app-emacs/initsplit/initsplit-1.6.ebuild
new file mode 100644
index 000000000000..0ae12b77a8c6
--- /dev/null
+++ b/app-emacs/initsplit/initsplit-1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/initsplit/initsplit-1.6.ebuild,v 1.1 2004/11/18 02:55:12 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Split customizations into different files"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki?InitSplit"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="virtual/emacs"
+
+SITEFILE=50initsplit-gentoo.el
+
+src_compile() {
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
diff --git a/app-emacs/initsplit/metadata.xml b/app-emacs/initsplit/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/initsplit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>