summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-10-15 21:46:04 +0000
committerUlrich Müller <ulm@gentoo.org>2012-10-15 21:46:04 +0000
commit4e8567164a54a9698caf84a8369f9c9f2030038c (patch)
treed60913a8e20eb69d4a07bfff906d6bd6be1a0a99 /app-emacs/yatex
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-4e8567164a54a9698caf84a8369f9c9f2030038c.tar.gz
gentoo-2-4e8567164a54a9698caf84a8369f9c9f2030038c.tar.bz2
gentoo-2-4e8567164a54a9698caf84a8369f9c9f2030038c.zip
Fix character code issue with Texinfo files, bug 438456.
(Portage version: 2.1.11.27/cvs/Linux x86_64, signed Manifest commit with key 7DC6EA25)
Diffstat (limited to 'app-emacs/yatex')
-rw-r--r--app-emacs/yatex/ChangeLog5
-rw-r--r--app-emacs/yatex/yatex-1.76.ebuild18
2 files changed, 14 insertions, 9 deletions
diff --git a/app-emacs/yatex/ChangeLog b/app-emacs/yatex/ChangeLog
index fedbe8827dd0..4797ba666816 100644
--- a/app-emacs/yatex/ChangeLog
+++ b/app-emacs/yatex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/yatex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.37 2012/10/14 18:50:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.38 2012/10/15 21:46:04 ulm Exp $
+
+ 15 Oct 2012; Ulrich Müller <ulm@gentoo.org> yatex-1.76.ebuild:
+ Fix character code issue with Texinfo files, bug 438456.
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> yatex-1.74.ebuild,
yatex-1.76.ebuild:
diff --git a/app-emacs/yatex/yatex-1.76.ebuild b/app-emacs/yatex/yatex-1.76.ebuild
index b37116b2e7d1..6479a32d3d98 100644
--- a/app-emacs/yatex/yatex-1.76.ebuild
+++ b/app-emacs/yatex/yatex-1.76.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.76.ebuild,v 1.10 2012/10/14 18:50:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.76.ebuild,v 1.11 2012/10/15 21:46:04 ulm Exp $
EAPI=4
@@ -24,12 +24,14 @@ src_compile() {
# byte-compilation fails (as of 1.74): yatexlib.el requires fonts
# that are only available under X
- local texi="yatexe.tex yahtmle.tex"
- use linguas_ja && texi+=" yatexj.tex yahtmlj.tex"
-
cd docs
- # makeinfo fails, so use Emacs to generate Info from Texinfo
- ${EMACS} ${EMACSFLAGS} -l texinfmt -f batch-texinfo-format ${texi} || die
+ makeinfo yatexe.tex yahtmle.tex || die
+
+ if use linguas_ja; then
+ iconv -f WINDOWS-31J -t UTF-8 yatexj.tex >yatex-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex >yahtml-ja.texi || die
+ makeinfo yatex-ja.texi yahtml-ja.texi || die
+ fi
}
src_install() {
@@ -38,12 +40,12 @@ src_install() {
insinto ${SITEETC}/${PN}
doins help/YATEXHLP.eng
- doinfo docs/yatex.info docs/yahtml.info
+ doinfo docs/yatex.info* docs/yahtml.info*
dodoc docs/*.eng
if use linguas_ja; then
doins help/YATEXHLP.jp
- doinfo docs/yatex-ja.info docs/yahtml-ja.info
+ doinfo docs/yatex-ja.info* docs/yahtml-ja.info*
dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc
fi
}