summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-04-06 10:48:14 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-04-06 10:48:14 +0000
commit5eeefe39eb7c160b9dae8d98d081b20cbbd7f5ce (patch)
tree7d48f26a2a99d37e513b9d4710b8d786c1d7365b /app-emacs/vm/vm-7.19-r3.ebuild
parentFixed bug #173510 (diff)
downloadgentoo-2-5eeefe39eb7c160b9dae8d98d081b20cbbd7f5ce.tar.gz
gentoo-2-5eeefe39eb7c160b9dae8d98d081b20cbbd7f5ce.tar.bz2
gentoo-2-5eeefe39eb7c160b9dae8d98d081b20cbbd7f5ce.zip
added fix for incorrect category of info file. Patch provided by Ulrich Mueller <ulm@kph.uni-mainz.de> in bug 173409
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-emacs/vm/vm-7.19-r3.ebuild')
-rw-r--r--app-emacs/vm/vm-7.19-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-7.19-r3.ebuild b/app-emacs/vm/vm-7.19-r3.ebuild
new file mode 100644
index 000000000000..ffa1d63b7b14
--- /dev/null
+++ b/app-emacs/vm/vm-7.19-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.19-r3.ebuild,v 1.1 2007/04/06 10:48:14 opfer Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="An emacs major mode for reading and writing e-mail with support for GPG and MIME."
+HOMEPAGE="http://www.wonderworks.com/vm/"
+SRC_URI="ftp://ftp.uni-mainz.de/pub/software/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.uu.net/networking/mail/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=51vm-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/vm-info-dir-fix-gentoo.patch"
+ epatch "${FILESDIR}/${P}-burst-digest.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}
+
+src_compile() {
+ make prefix="${D}/usr" \
+ INFODIR="${D}/usr/share/info" \
+ LISPDIR="${D}/${SITELISP}/vm" \
+ PIXMAPDIR="${D}/usr/share/pixmaps/vm" \
+ all || die
+}
+
+src_install() {
+ make prefix="${D}/usr" \
+ INFODIR="${D}/usr/share/info" \
+ LISPDIR="${D}/${SITELISP}/vm" \
+ PIXMAPDIR="${D}/usr/share/pixmaps/vm" \
+ install || die
+ elisp-install ${PN} *.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README
+}