summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/typing
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/typing')
-rw-r--r--app-emacs/typing/ChangeLog11
-rw-r--r--app-emacs/typing/files/50typing-gentoo.el6
-rw-r--r--app-emacs/typing/files/digest-typing-1.1.21
-rw-r--r--app-emacs/typing/typing-1.1.2.ebuild38
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/typing/ChangeLog b/app-emacs/typing/ChangeLog
new file mode 100644
index 000000000000..41a43f6ec3ed
--- /dev/null
+++ b/app-emacs/typing/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/typing
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/typing/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*typing-1.1.2 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ typing-1.1.2.ebuild, files/50typing-gentoo.el,
+ files/digest-typing-1.1.2 :
+
+ Initial import.
diff --git a/app-emacs/typing/files/50typing-gentoo.el b/app-emacs/typing/files/50typing-gentoo.el
new file mode 100644
index 000000000000..caa7513d3e3f
--- /dev/null
+++ b/app-emacs/typing/files/50typing-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; typing site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'typing-of-emacs "typing" "The Typing of Emacs, a game." t)
diff --git a/app-emacs/typing/files/digest-typing-1.1.2 b/app-emacs/typing/files/digest-typing-1.1.2
new file mode 100644
index 000000000000..c6ddf37bd6c2
--- /dev/null
+++ b/app-emacs/typing/files/digest-typing-1.1.2
@@ -0,0 +1 @@
+MD5 06328056d726d3f6e61f539f0693c05c typing-1.1.2.tar.bz2 4898
diff --git a/app-emacs/typing/typing-1.1.2.ebuild b/app-emacs/typing/typing-1.1.2.ebuild
new file mode 100644
index 000000000000..137b0d8563aa
--- /dev/null
+++ b/app-emacs/typing/typing-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/typing/typing-1.1.2.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION='The Typing of Emacs -- an Elisp parody of The Typing of the Dead for Dreamcast'
+HOMEPAGE="ftp://ftp.cis.ohio-state.edu/pub/emacs-lisp/archive/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50typing-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/typing.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}