summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/speedbar/speedbar-0.14_beta4.ebuild
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/speedbar/speedbar-0.14_beta4.ebuild')
-rw-r--r--app-emacs/speedbar/speedbar-0.14_beta4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/speedbar/speedbar-0.14_beta4.ebuild b/app-emacs/speedbar/speedbar-0.14_beta4.ebuild
new file mode 100644
index 000000000000..1c3631bed63d
--- /dev/null
+++ b/app-emacs/speedbar/speedbar-0.14_beta4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/speedbar/speedbar-0.14_beta4.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Allows you to create a special frame with a specialized directory listing in it."
+HOMEPAGE="http://cedet.sourceforge.net/speedbar.shtml"
+SRC_URI="mirror://sourceforge/cedet/${P/_/}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P/_/}"
+
+SITEFILE=50speedbar-gentoo.el
+
+src_compile() {
+ make || die
+ make opt || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.xpm
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ChangeLog INSTALL
+ doinfo speedbar.info
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}