summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-22 18:47:05 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-22 18:47:05 +0000
commit451c5ddf31e7ddd8b1955f5352a1d486f24a002c (patch)
tree79dec29d3d9f1b683d725c2f36867b2764690b5d /app-emacs/sml-mode
parentRemove needless junit dep; some polishing. (diff)
downloadgentoo-2-451c5ddf31e7ddd8b1955f5352a1d486f24a002c.tar.gz
gentoo-2-451c5ddf31e7ddd8b1955f5352a1d486f24a002c.tar.bz2
gentoo-2-451c5ddf31e7ddd8b1955f5352a1d486f24a002c.zip
Load sml-mode-startup from sitefile. make -> emake.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/ChangeLog6
-rw-r--r--app-emacs/sml-mode/files/51sml-mode-gentoo.el5
-rw-r--r--app-emacs/sml-mode/sml-mode-4.0.ebuild18
3 files changed, 17 insertions, 12 deletions
diff --git a/app-emacs/sml-mode/ChangeLog b/app-emacs/sml-mode/ChangeLog
index 682b8df5d8b4..5001955da353 100644
--- a/app-emacs/sml-mode/ChangeLog
+++ b/app-emacs/sml-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/sml-mode
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.8 2007/02/08 18:17:56 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.9 2007/04/22 18:47:05 ulm Exp $
+
+ 22 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +files/51sml-mode-gentoo.el,
+ sml-mode-4.0.ebuild:
+ Load sml-mode-startup from sitefile. Use emake, not make. Don't dodoc INSTALL.
08 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
sml-mode-3.9.5.ebuild:
diff --git a/app-emacs/sml-mode/files/51sml-mode-gentoo.el b/app-emacs/sml-mode/files/51sml-mode-gentoo.el
new file mode 100644
index 000000000000..6bc0281b6d33
--- /dev/null
+++ b/app-emacs/sml-mode/files/51sml-mode-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; sml-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(load "sml-mode-startup" nil t)
diff --git a/app-emacs/sml-mode/sml-mode-4.0.ebuild b/app-emacs/sml-mode/sml-mode-4.0.ebuild
index 18a63de91030..d6ea8784ee86 100644
--- a/app-emacs/sml-mode/sml-mode-4.0.ebuild
+++ b/app-emacs/sml-mode/sml-mode-4.0.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-4.0.ebuild,v 1.1 2005/05/03 08:46:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-4.0.ebuild,v 1.2 2007/04/22 18:47:05 ulm Exp $
inherit elisp
DESCRIPTION="Emacs major mode for editing Standard ML"
HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
SRC_URI="http://www.iro.umontreal.ca/~monnier/elisp/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~alpha ~ppc-macos ~amd64"
IUSE=""
-SITEFILE=50sml-mode-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cat ${FILESDIR}/${SITEFILE} ${S}/sml-mode-startup.el >${WORKDIR}/${SITEFILE}
-}
+SITEFILE=51${PN}-gentoo.el
src_compile() {
- make || die
+ emake || die "emake failed"
}
src_install() {
elisp-install ${PN} *.el *.elc
- elisp-site-file-install ${WORKDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
doinfo *.info*
- dodoc BUGS ChangeLog NEWS README TODO INSTALL
+ dodoc BUGS ChangeLog NEWS README TODO
}