summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 02:13:16 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 02:13:16 +0000
commitbf471fc800e146c700882f0ce03bf93ecf1ec2a8 (patch)
tree02697970e0219845af1108dc0ba2638f142a6f6d /app-emacs/sml-mode/sml-mode-3.9.5.ebuild
parentbug 18860 (diff)
downloadgentoo-2-bf471fc800e146c700882f0ce03bf93ecf1ec2a8.tar.gz
gentoo-2-bf471fc800e146c700882f0ce03bf93ecf1ec2a8.tar.bz2
gentoo-2-bf471fc800e146c700882f0ce03bf93ecf1ec2a8.zip
bug 18860
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-3.9.5.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-3.9.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-3.9.5.ebuild b/app-emacs/sml-mode/sml-mode-3.9.5.ebuild
new file mode 100644
index 000000000000..45000a2d407a
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-3.9.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-3.9.5.ebuild,v 1.1 2003/08/28 02:13:14 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="ftp://ftp.research.bell-labs.com/dist/smlnj/contrib/emacs/"
+SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/contrib/emacs/sml-mode-3.9.5.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S=${WORKDIR}/${P}
+
+SITEFILE=50sml-mode-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cat ${FILESDIR}/${SITEFILE} ${S}/sml-mode-startup.el >${WORKDIR}/${SITEFILE}
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${WORKDIR}/${SITEFILE}
+ doinfo *.info*
+ dodoc BUGS ChangeLog NEWS README TODO INSTALL
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}