summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-08-23 23:34:21 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-08-23 23:34:21 +0000
commit7d1a556a7091f58c22cedc0d672fabd0ce9355e1 (patch)
tree3d9f44d7313b02cf53f4469f796e1468866f29be /app-emacs/riece/riece-1.0.2.ebuild
parentsmall LICENSE fix (Manifest recommit) (diff)
downloadgentoo-2-7d1a556a7091f58c22cedc0d672fabd0ce9355e1.tar.gz
gentoo-2-7d1a556a7091f58c22cedc0d672fabd0ce9355e1.tar.bz2
gentoo-2-7d1a556a7091f58c22cedc0d672fabd0ce9355e1.zip
Version bumped.
Diffstat (limited to 'app-emacs/riece/riece-1.0.2.ebuild')
-rw-r--r--app-emacs/riece/riece-1.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-1.0.2.ebuild b/app-emacs/riece/riece-1.0.2.ebuild
new file mode 100644
index 000000000000..61614fb1ff4b
--- /dev/null
+++ b/app-emacs/riece/riece-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-1.0.2.ebuild,v 1.1 2004/08/23 23:34:21 matsuu Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://wiliki.designflaw.org/riece.cgi"
+SRC_URI="http://wiliki.designflaw.org/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~macos ~amd64"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}