summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2012-08-10 23:15:45 +0000
committerChristian Faulhammer <fauli@gentoo.org>2012-08-10 23:15:45 +0000
commit970481713ff502491d6ecb35351f589083784b1d (patch)
tree131eae101bf249e514b012cd59376f7a650b5be8 /app-emacs/python-mode
parentRemove dropped deps by upstream. (diff)
downloadgentoo-2-970481713ff502491d6ecb35351f589083784b1d.tar.gz
gentoo-2-970481713ff502491d6ecb35351f589083784b1d.tar.bz2
gentoo-2-970481713ff502491d6ecb35351f589083784b1d.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog8
-rw-r--r--app-emacs/python-mode/python-mode-6.0.10.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 3dbfa04a53c6..150479d4a782 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/python-mode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.61 2012/03/07 16:54:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.62 2012/08/10 23:15:45 fauli Exp $
+
+*python-mode-6.0.10 (10 Aug 2012)
+
+ 10 Aug 2012; Christian Faulhammer <fauli@gentoo.org>
+ +python-mode-6.0.10.ebuild:
+ version bump
*python-mode-6.0.5 (07 Mar 2012)
diff --git a/app-emacs/python-mode/python-mode-6.0.10.ebuild b/app-emacs/python-mode/python-mode-6.0.10.ebuild
new file mode 100644
index 000000000000..f7ac485af236
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.0.10.ebuild,v 1.1 2012/08/10 23:15:45 fauli Exp $
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest and pymacs are in their own packages,"
+ elog "app-emacs/doctest-mode and app-emacs/pymacs, respectively."
+}