summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-03 09:37:13 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-03 09:37:13 +0000
commit75013533b028ebf0170ddf5ca0ab15c7a6700f79 (patch)
tree7dc9d2231297ebcbdfe2d796ad7248ef55fdb276 /app-emacs/python-mode
parentAdded to ~ppc (diff)
downloadgentoo-2-75013533b028ebf0170ddf5ca0ab15c7a6700f79.tar.gz
gentoo-2-75013533b028ebf0170ddf5ca0ab15c7a6700f79.tar.bz2
gentoo-2-75013533b028ebf0170ddf5ca0ab15c7a6700f79.zip
Version bumped. This closes bug #88704.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog7
-rw-r--r--app-emacs/python-mode/Manifest2
-rw-r--r--app-emacs/python-mode/files/digest-python-mode-4.702
-rw-r--r--app-emacs/python-mode/python-mode-4.70.ebuild40
4 files changed, 50 insertions, 1 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 49e7fa76f978..6f19fdd2e0ee 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/python-mode
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.15 2005/05/03 08:55:58 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.16 2005/05/03 09:37:13 usata Exp $
+
+*python-mode-4.70 (03 May 2005)
+
+ 03 May 2005; Mamoru KOMACHI <usata@gentoo.org> +python-mode-4.70.ebuild:
+ Version bumped. This closes bug #88704.
03 May 2005; Mamoru KOMACHI <usata@gentoo.org> +files/setup.py,
python-mode-4.63-r1.ebuild:
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index d602b1f2a0b8..e0e43af38dbe 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -2,8 +2,10 @@ MD5 0ecb08054b678f7912068f673c5a2a54 python-mode-4.6.ebuild 773
MD5 f62221159e366608d5439bb7e4850a92 ChangeLog 1802
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 711dc65d123ffb27b7f8df92fe8dcf12 python-mode-4.63-r1.ebuild 880
+MD5 a05738d59b93046c137dc3d3b357ed31 python-mode-4.70.ebuild 999
MD5 7842a604f7fbeda6be9d9b86f6d143bb files/digest-python-mode-4.6 67
MD5 b16866ae5b915c74ccb69ff8591a4ada files/50python-mode-gentoo.el 334
MD5 2f5fc2b5c01b7202432d5e420db9d66b files/55python-mode-gentoo.el 505
MD5 6d29bd6bc2d870795491141dcb821e06 files/setup.py 86
MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-4.63-r1 71
+MD5 0f84fd7d46723117bcf57db5a7f4eed8 files/digest-python-mode-4.70 143
diff --git a/app-emacs/python-mode/files/digest-python-mode-4.70 b/app-emacs/python-mode/files/digest-python-mode-4.70
new file mode 100644
index 000000000000..b4aa1fbe92d5
--- /dev/null
+++ b/app-emacs/python-mode/files/digest-python-mode-4.70
@@ -0,0 +1,2 @@
+MD5 41adbb7bc4079d9aac3323e962c1e542 python-mode-1.0alpha.tar.gz 53666
+MD5 4e7c169a502120f7084cfa0c3eba411f python-mode_4.70.orig.tar.gz 52449
diff --git a/app-emacs/python-mode/python-mode-4.70.ebuild b/app-emacs/python-mode/python-mode-4.70.ebuild
new file mode 100644
index 000000000000..08b10045536f
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-4.70.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.70.ebuild,v 1.1 2005/05/03 09:37:13 usata Exp $
+
+inherit distutils elisp
+
+IUSE=""
+
+MY_P="${PN}-1.0alpha"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Python Mode is a major editing mode for the XEmacs and FSF Emacs text editors."
+HOMEPAGE="http://sourceforge.net/projects/python-mode/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos ~amd64 ~ppc"
+
+DEPEND="app-emacs/pymacs"
+
+SITEFILE="55python-mode-gentoo.el"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack ${PN}_${PV}.orig.tar.gz
+ cp ${WORKDIR}/${P}.orig/* ${S}
+ cp ${FILESDIR}/setup.py ${S}
+}
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ distutils_src_install
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}