summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-11 10:29:46 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-11 10:29:46 +0000
commit1d7c7071210cdef1335c88f47034964be3b47e8c (patch)
tree5ba5e1d416ddf8d47d7442e9d4000099a79a4d90 /app-emacs/python-mode
parentkeyworded x86 (Manifest recommit) (diff)
downloadgentoo-2-1d7c7071210cdef1335c88f47034964be3b47e8c.tar.gz
gentoo-2-1d7c7071210cdef1335c88f47034964be3b47e8c.tar.bz2
gentoo-2-1d7c7071210cdef1335c88f47034964be3b47e8c.zip
Version bumped. Dropped ppc and ~amd64 keywords; bug #51435.
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog7
-rw-r--r--app-emacs/python-mode/Manifest7
-rw-r--r--app-emacs/python-mode/files/digest-python-mode-4.631
-rw-r--r--app-emacs/python-mode/python-mode-4.63.ebuild31
4 files changed, 43 insertions, 3 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 0e40e9c7734d..66e5a67475e9 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/python-mode
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.6 2004/09/11 13:52:55 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.7 2004/11/11 10:29:46 usata Exp $
+
+*python-mode-4.63 (11 Nov 2004)
+
+ 11 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> +python-mode-4.63.ebuild:
+ Version bumped. Dropped ppc and ~amd64 keywords; bug #51435.
11 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> python-mode-4.6.ebuild:
Added amd64 keyword, closing #60694.
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index fb3c85db4044..7f8f9a6854b2 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -1,5 +1,8 @@
-MD5 5ec0d617968fa3436913945c7713994f python-mode-4.6.ebuild 772
MD5 b1e4b7bdb3fee0dd37b957f9056621e2 ChangeLog 705
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
-MD5 7842a604f7fbeda6be9d9b86f6d143bb files/digest-python-mode-4.6 67
+MD5 5ec0d617968fa3436913945c7713994f python-mode-4.6.ebuild 772
+MD5 179d9ff21c3c4a01e90088941964e154 python-mode-4.63.ebuild 709
MD5 b16866ae5b915c74ccb69ff8591a4ada files/50python-mode-gentoo.el 334
+MD5 7842a604f7fbeda6be9d9b86f6d143bb files/digest-python-mode-4.6 67
+MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-1.0_alpha 71
+MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-4.63 71
diff --git a/app-emacs/python-mode/files/digest-python-mode-4.63 b/app-emacs/python-mode/files/digest-python-mode-4.63
new file mode 100644
index 000000000000..56a5c4f651b5
--- /dev/null
+++ b/app-emacs/python-mode/files/digest-python-mode-4.63
@@ -0,0 +1 @@
+MD5 41adbb7bc4079d9aac3323e962c1e542 python-mode-1.0alpha.tar.gz 53666
diff --git a/app-emacs/python-mode/python-mode-4.63.ebuild b/app-emacs/python-mode/python-mode-4.63.ebuild
new file mode 100644
index 000000000000..a644b9be06a7
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-4.63.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63.ebuild,v 1.1 2004/11/11 10:29:46 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P="${PN}-1.0alpha"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Python Mode is a major editing mode for the XEmacs and FSF Emacs text editors."
+HOMEPAGE="http://sourceforge.net/projects/python-mode/"
+SRC_URI="mirror://sourceforge/python-mode/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos"
+
+DEPEND="app-emacs/pymacs"
+
+SITEFILE="50python-mode-gentoo.el"
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.py
+ elisp-site-file-install ${FILESDIR}/50python-mode-gentoo.el
+}