summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-04-12 18:10:12 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-04-12 18:10:12 +0000
commited77ef89426c19b8a7218ff97cbd59472a5163f2 (patch)
tree7da6d952dc0688dbf980289e5f676d5d34a9f1a7 /app-emacs/psgml/psgml-1.3.2.ebuild
parentversion bump, reported by user on http://forums.gentoo.org/viewtopic-p-624134... (diff)
downloadgentoo-2-ed77ef89426c19b8a7218ff97cbd59472a5163f2.tar.gz
gentoo-2-ed77ef89426c19b8a7218ff97cbd59472a5163f2.tar.bz2
gentoo-2-ed77ef89426c19b8a7218ff97cbd59472a5163f2.zip
version bump, reported by user on http://forums.gentoo.org/viewtopic-p-6241340.html
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-emacs/psgml/psgml-1.3.2.ebuild')
-rw-r--r--app-emacs/psgml/psgml-1.3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/psgml/psgml-1.3.2.ebuild b/app-emacs/psgml/psgml-1.3.2.ebuild
new file mode 100644
index 000000000000..093f0c9a6757
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/psgml/psgml-1.3.2.ebuild,v 1.1 2010/04/12 18:10:12 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="http://sourceforge.net/projects/psgml/"
+SRC_URI="mirror://sourceforge/psgml/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="app-text/openjade"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50psgml-gentoo.el
+
+src_compile() {
+ emacs --batch --no-site-file --no-init-file \
+ --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.map || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog INSTALL README.psgml psgml.ps || die
+ doinfo psgml-api.info psgml.info || die
+}