summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-25 15:41:00 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-25 15:41:00 +0000
commitf75ae06718df55001f35ad71aab55e4ffe4e8a9d (patch)
tree7ea0e69152e51b70e57643e9ab4dadd5ceef0876 /app-emacs/org-mode
parentbump to 2.11, remove 2.9 (diff)
downloadgentoo-2-f75ae06718df55001f35ad71aab55e4ffe4e8a9d.tar.gz
gentoo-2-f75ae06718df55001f35ad71aab55e4ffe4e8a9d.tar.bz2
gentoo-2-f75ae06718df55001f35ad71aab55e4ffe4e8a9d.zip
Version bump.
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/org-mode')
-rw-r--r--app-emacs/org-mode/ChangeLog8
-rw-r--r--app-emacs/org-mode/org-mode-7.7.ebuild11
-rw-r--r--app-emacs/org-mode/org-mode-7.8.02.ebuild51
3 files changed, 62 insertions, 8 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index e598e6a7df90..cd8307bf3fe1 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.134 2011/10/09 10:26:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.135 2011/12/25 15:41:00 ulm Exp $
+
+*org-mode-7.8.02 (25 Dec 2011)
+
+ 25 Dec 2011; Ulrich Mueller <ulm@gentoo.org> org-mode-7.7.ebuild,
+ +org-mode-7.8.02.ebuild:
+ Version bump.
09 Oct 2011; Ulrich Mueller <ulm@gentoo.org> -org-mode-7.6.ebuild,
org-mode-7.7.ebuild:
diff --git a/app-emacs/org-mode/org-mode-7.7.ebuild b/app-emacs/org-mode/org-mode-7.7.ebuild
index d0d7cc33932b..fd1ef2f8592c 100644
--- a/app-emacs/org-mode/org-mode-7.7.ebuild
+++ b/app-emacs/org-mode/org-mode-7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-7.7.ebuild,v 1.2 2011/10/09 10:26:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-7.7.ebuild,v 1.3 2011/12/25 15:41:00 ulm Exp $
EAPI=4
NEED_EMACS=22
@@ -17,14 +17,11 @@ KEYWORDS="~amd64 ~ppc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-macos"
IUSE="contrib"
S="${WORKDIR}/org-${PV}"
+# Remove autoload file to make sure that it is regenerated with
+# the right Emacs version.
+ELISP_REMOVE="lisp/org-install.el"
SITEFILE="50${PN}-gentoo.el"
-src_prepare() {
- # Remove autoload file to make sure that it is regenerated with
- # the right Emacs version.
- rm -f lisp/org-install.el
-}
-
src_compile() {
default
}
diff --git a/app-emacs/org-mode/org-mode-7.8.02.ebuild b/app-emacs/org-mode/org-mode-7.8.02.ebuild
new file mode 100644
index 000000000000..fe7aac566b72
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-7.8.02.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-7.8.02.ebuild,v 1.1 2011/12/25 15:41:00 ulm Exp $
+
+EAPI=4
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.3 contrib? ( GPL-2 MIT as-is )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-macos"
+IUSE="contrib"
+
+S="${WORKDIR}/org-${PV}"
+# Remove autoload file to make sure that it is regenerated with
+# the right Emacs version.
+ELISP_REMOVE="lisp/org-install.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake \
+ prefix="${ED}/usr" \
+ lispdir="${ED}${SITELISP}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ install
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}/${SITEFILE}"
+
+ if use contrib; then
+ elisp-install ${PN}/contrib contrib/lisp/*org*.el || die
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/README contrib/babel contrib/odt contrib/scripts
+ find "${ED}/usr/share/doc/${PF}/contrib" -type f -name '.*' \
+ -exec rm -f '{}' '+'
+ sed -ie 's:\(.*@SITELISP@\)\(.*\):&\n\1/contrib\2:' \
+ "${T}/${SITEFILE}" || die
+ fi
+
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo doc/org
+ dodoc README doc/org.pdf doc/orgcard.pdf doc/orgguide.pdf
+}