summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-05-27 11:06:27 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-05-27 11:06:27 +0000
commit8a87c696a6c4354d049794394028355fbd87586b (patch)
tree74447a26649a9b3b8fd90b4102d7a570a7c2e411 /app-emacs/org-mode
parentstable x86, bug 271136 (diff)
downloadgentoo-2-8a87c696a6c4354d049794394028355fbd87586b.tar.gz
gentoo-2-8a87c696a6c4354d049794394028355fbd87586b.tar.bz2
gentoo-2-8a87c696a6c4354d049794394028355fbd87586b.zip
version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'app-emacs/org-mode')
-rw-r--r--app-emacs/org-mode/ChangeLog8
-rw-r--r--app-emacs/org-mode/org-mode-6.27a.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index 05cff68ba900..fab55f18b334 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.70 2009/05/24 15:23:39 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.71 2009/05/27 11:06:27 fauli Exp $
+
+*org-mode-6.27a (27 May 2009)
+
+ 27 May 2009; Christian Faulhammer <fauli@gentoo.org>
+ +org-mode-6.27a.ebuild:
+ version bump
*org-mode-6.27 (24 May 2009)
diff --git a/app-emacs/org-mode/org-mode-6.27a.ebuild b/app-emacs/org-mode/org-mode-6.27a.ebuild
new file mode 100644
index 000000000000..ebc0442e952f
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-6.27a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-6.27a.ebuild,v 1.1 2009/05/27 11:06:27 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/org-${PV}"
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ # remove autoload file to make sure that it is regenerated with
+ # the right Emacs version
+ rm -f lisp/org-install.el
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ lispdir="${D}${SITELISP}/${PN}" \
+ infodir="${D}/usr/share/info" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ mv doc/org doc/org.info
+ doinfo doc/org.info || die "doinfo failed"
+ dodoc README ChangeLog Changes.org doc/org.pdf doc/orgcard.pdf \
+ || die "dodoc failed"
+}