summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-29 17:08:59 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-29 17:08:59 +0000
commit7b5562c0ad9d43c12a65f5323bc02e0a2c484e02 (patch)
tree8ea0d8c967c4280303eac546326f18ed6407b1db /app-emacs/ocaml-mode
parentSparc stable --- Security Bug #211449 --- verified (remote) with ps and pdf. (diff)
downloadgentoo-2-7b5562c0ad9d43c12a65f5323bc02e0a2c484e02.tar.gz
gentoo-2-7b5562c0ad9d43c12a65f5323bc02e0a2c484e02.tar.bz2
gentoo-2-7b5562c0ad9d43c12a65f5323bc02e0a2c484e02.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog9
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.10.2.ebuild24
2 files changed, 31 insertions, 2 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
index 6a04e6628ddc..35dd4760af52 100644
--- a/app-emacs/ocaml-mode/ChangeLog
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ocaml-mode
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.27 2007/11/27 14:31:31 armin76 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.28 2008/02/29 17:08:59 ulm Exp $
+
+*ocaml-mode-3.10.2 (29 Feb 2008)
+
+ 29 Feb 2008; Ulrich Mueller <ulm@gentoo.org> +ocaml-mode-3.10.2.ebuild:
+ Version bump.
27 Nov 2007; Raúl Porcel <armin76@gentoo.org>
ocaml-mode-3.09.3-r1.ebuild:
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.10.2.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.10.2.ebuild
new file mode 100644
index 000000000000..132d4a069374
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.10.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.10.2.ebuild,v 1.1 2008/02/29 17:08:59 ulm Exp $
+
+inherit elisp
+
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/emacs"
+SITEFILE=50${PN}-gentoo.el
+DOCS="README README.itz"
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+}