summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-16 04:21:14 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-16 04:21:14 +0000
commit4e795ff60be6cd74713ac989023d645cd35097ec (patch)
treec1b86c5935fad1d3dcbb2b987ddd67ac3961c7a1 /app-emacs/mpg123-el/mpg123-el-1.42.ebuild
parentversion bump (bug #90098) (diff)
downloadgentoo-2-4e795ff60be6cd74713ac989023d645cd35097ec.tar.gz
gentoo-2-4e795ff60be6cd74713ac989023d645cd35097ec.tar.bz2
gentoo-2-4e795ff60be6cd74713ac989023d645cd35097ec.zip
use toolchain-funcs.eclass instead of gcc.eclass; bug #92745.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-emacs/mpg123-el/mpg123-el-1.42.ebuild')
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.42.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-emacs/mpg123-el/mpg123-el-1.42.ebuild b/app-emacs/mpg123-el/mpg123-el-1.42.ebuild
index afe89cc1b417..ba9b831632bf 100644
--- a/app-emacs/mpg123-el/mpg123-el-1.42.ebuild
+++ b/app-emacs/mpg123-el/mpg123-el-1.42.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.42.ebuild,v 1.4 2005/01/01 13:54:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.42.ebuild,v 1.5 2005/05/16 04:19:10 usata Exp $
-inherit gcc elisp
+inherit toolchain-funcs elisp
IUSE="oggvorbis"
@@ -24,8 +24,9 @@ KEYWORDS="x86"
SITEFILE="50mpg123-el-gentoo.el"
src_compile(){
- $(gcc-getCC) ${CFLAGS} -o tagput tagput.c || die
- $(gcc-getCC) ${CFLAGS} -o id3put id3put.c || die
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+ "$(tc-getCC)" ${CFLAGS} -o tagput tagput.c || die
+ "$(tc-getCC)" ${CFLAGS} -o id3put id3put.c || die
elisp-compile *.el
}