summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-13 17:29:40 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-13 17:29:40 +0000
commiteabc6187c5426c18bde78bf66df78b08723b56ca (patch)
tree83f04cf7aadd648786c743d220ab21e231834393 /app-emacs/jde
parentVersion bump. (diff)
downloadgentoo-2-eabc6187c5426c18bde78bf66df78b08723b56ca.tar.gz
gentoo-2-eabc6187c5426c18bde78bf66df78b08723b56ca.tar.bz2
gentoo-2-eabc6187c5426c18bde78bf66df78b08723b56ca.zip
Version bump, bug 394365. This version depends on CEDET included with >=emacs-23.2. Thanks to Alex Bennee <alex@bennee.com>.
(Portage version: 2.1.10.40/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/jde')
-rw-r--r--app-emacs/jde/ChangeLog12
-rw-r--r--app-emacs/jde/files/jde-2.4.1-doc-directory.patch53
-rw-r--r--app-emacs/jde/files/jde-2.4.1-semantic-emacs-24.patch36
-rw-r--r--app-emacs/jde/jde-2.4.1_pre20110622.ebuild72
4 files changed, 171 insertions, 2 deletions
diff --git a/app-emacs/jde/ChangeLog b/app-emacs/jde/ChangeLog
index 6a7dc56a1a0c..a4c3cc941a23 100644
--- a/app-emacs/jde/ChangeLog
+++ b/app-emacs/jde/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/jde
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.42 2010/10/14 16:29:11 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.43 2011/12/13 17:29:40 ulm Exp $
+
+*jde-2.4.1_pre20110622 (13 Dec 2011)
+
+ 13 Dec 2011; Ulrich Mueller <ulm@gentoo.org> +jde-2.4.1_pre20110622.ebuild,
+ +files/jde-2.4.1-doc-directory.patch,
+ +files/jde-2.4.1-semantic-emacs-24.patch:
+ Version bump, bug 394365. This version depends on CEDET included with
+ >=emacs-23.2. Thanks to Alex Bennee <alex@bennee.com>.
14 Oct 2010; Ulrich Mueller <ulm@gentoo.org> -files/70jde-gentoo-2.3.5.1.el:
More cleanup.
diff --git a/app-emacs/jde/files/jde-2.4.1-doc-directory.patch b/app-emacs/jde/files/jde-2.4.1-doc-directory.patch
new file mode 100644
index 000000000000..c96fcd861594
--- /dev/null
+++ b/app-emacs/jde/files/jde-2.4.1-doc-directory.patch
@@ -0,0 +1,53 @@
+Move definition of jde-find-jde-doc-directory to jde-util.el.
+
+--- jdee-orig/lisp/beanshell.el
++++ jdee/lisp/beanshell.el
+@@ -82,7 +82,7 @@
+ (eval-when-compile
+ (require 'cl))
+
+-(declare-function jde-find-jde-doc-directory "jde" nil)
++(require 'jde-util)
+
+ (defgroup bsh nil
+ "Customizations for the Emacs inteface to Pat Neimeyer's Java
+--- jdee-orig/lisp/jde-util.el
++++ jdee/lisp/jde-util.el
+@@ -139,6 +139,17 @@
+ (if dir dir (jde-root)))
+ (jde-root))))
+
++(defun jde-find-jde-doc-directory ()
++ "Return the path of the JDE documentation directory.
++Returns nil if the directory cannot be found. At some
++point, XEmacs will include the JDE. Versions of XEmacs
++that include JDE will store the JDE doc in a data
++directory called jde. On all other Emacs versions, the JDE
++expects to find the documentation in a subdirectory
++named doc of the directory that contains the file
++jde.el."
++ (jde-find-jde-data-directory))
++
+ (defun jde-temp-directory ()
+ "Get the location used by the host system to store temporary files."
+ (or (if (boundp 'temporary-file-directory) temporary-file-directory)
+--- jdee-orig/lisp/jde.el
++++ jdee/lisp/jde.el
+@@ -1762,17 +1762,6 @@
+
+
+ ;; JDE help
+-(defun jde-find-jde-doc-directory ()
+- "Return the path of the JDE documentation directory.
+-Returns nil if the directory cannot be found. At some
+-point, XEmacs will include the JDE. Versions of XEmacs
+-that include JDE will store the JDE doc in a data
+-directory called jde. On all other Emacs versions, the JDE
+-expects to find the documentation in a subdirectory
+-named doc of the directory that contains the file
+-jde.el."
+- (jde-find-jde-data-directory))
+-
+ (defcustom jde-html-directory
+ (expand-file-name "doc/html" (jde-find-jde-doc-directory))
+ "Directory of the JDE HTML documentation."
diff --git a/app-emacs/jde/files/jde-2.4.1-semantic-emacs-24.patch b/app-emacs/jde/files/jde-2.4.1-semantic-emacs-24.patch
new file mode 100644
index 000000000000..cafcc5ae9c4d
--- /dev/null
+++ b/app-emacs/jde/files/jde-2.4.1-semantic-emacs-24.patch
@@ -0,0 +1,36 @@
+semantic-add-minor-mode accepts two arguments only.
+http://bzr.savannah.gnu.org/lh/emacs/trunk/revision/100114
+
+--- jdee-orig/lisp/jde-bug.el
++++ jdee/lisp/jde-bug.el
+@@ -570,7 +570,7 @@
+
+ (run-hook-with-args 'jde-bug-minor-mode-hook jde-bug-minor-mode))
+
+-(semantic-add-minor-mode 'jde-bug-minor-mode " JDEbug" jde-bug-mode-map)
++(semantic-add-minor-mode 'jde-bug-minor-mode " JDEbug")
+
+ ;; (fmakunbound 'jde-bug-key-bindings)
+ (defcustom jde-bug-key-bindings
+--- jdee-orig/lisp/jde-jdb.el
++++ jdee/lisp/jde-jdb.el
+@@ -1830,7 +1830,7 @@
+ (if (featurep 'xemacs)
+ (easy-menu-remove jde-jdb-xemacs-menu-spec))))
+
+-(semantic-add-minor-mode 'jde-jdb-minor-mode " jdb" jde-jdb-mode-map)
++(semantic-add-minor-mode 'jde-jdb-minor-mode " jdb")
+
+
+ ;; (fmakunbound 'jde-jdb-key-bindings)
+--- jdee-orig/lisp/jde-plugins.el
++++ jdee/lisp/jde-plugins.el
+@@ -194,7 +194,7 @@
+ (easy-menu-add menu-spec jde-plugin-mode-map)
+ (easy-menu-remove menu-spec))))))
+
+-(semantic-add-minor-mode 'jde-plugin-minor-mode " plugin" jde-plugin-mode-map)
++(semantic-add-minor-mode 'jde-plugin-minor-mode " plugin")
+
+
+ (provide 'jde-plugins)
diff --git a/app-emacs/jde/jde-2.4.1_pre20110622.ebuild b/app-emacs/jde/jde-2.4.1_pre20110622.ebuild
new file mode 100644
index 000000000000..f3c23ccb308f
--- /dev/null
+++ b/app-emacs/jde/jde-2.4.1_pre20110622.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/jde-2.4.1_pre20110622.ebuild,v 1.1 2011/12/13 17:29:40 ulm Exp $
+
+EAPI=4
+NEED_EMACS=23
+WANT_ANT_TASKS="ant-nodeps ant-contrib"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 elisp eutils
+
+DESCRIPTION="Java Development Environment for Emacs"
+HOMEPAGE="http://jdee.sourceforge.net/"
+# taken from: http://jdee.svn.sourceforge.net/viewvc/jdee/trunk/jdee/?view=tar&pathrev=254
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.3
+ app-emacs/elib
+ virtual/emacs-cedet
+ dev-java/bsh
+ dev-java/junit:0
+ dev-util/checkstyle"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/jdee"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.0.1-fix-paths-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-2.4.0.1-classpath-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-2.4.1-doc-directory.patch"
+ epatch "${FILESDIR}/${PN}-2.4.1-semantic-emacs-24.patch"
+
+ local bshjar csjar
+ bshjar=$(java-pkg_getjar --build-only bsh bsh.jar) || die
+ csjar=$(java-pkg_getjar --build-only checkstyle checkstyle.jar) || die
+ sed -e "s:@BSH_JAR@:${bshjar}:;s:@CHECKSTYLE_JAR@:${csjar}:" \
+ -e "s:@PF@:${PF}:" "${FILESDIR}/${SITEFILE}" >"${SITEFILE}" || die
+
+ cd java/lib || die
+ java-pkg_jar-from --build-only checkstyle checkstyle.jar checkstyle-all.jar
+ java-pkg_jar-from junit
+ java-pkg_jar-from bsh
+}
+
+src_compile() {
+ eant bindist -Delib.dir="${EPREFIX}${SITELISP}/elib"
+ use doc && eant source-doc
+}
+
+src_install() {
+ local dist="dist/jdee-${PV%_*}"
+
+ java-pkg_dojar ${dist}/java/lib/jde.jar
+ insinto "${JAVA_PKG_SHAREPATH}"
+ doins -r java/bsh-commands
+
+ use source && java-pkg_dosrc java/src/*
+ use doc && java-pkg_dojavadoc ${dist}/doc/java/api
+
+ elisp-install ${PN} ${dist}/lisp/*.{el,elc} || die
+ elisp-site-file-install "${SITEFILE}" || die
+
+ dobin ${dist}/lisp/jtags
+
+ dohtml -r doc/html/*
+}