summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-03 19:47:05 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-03 19:47:05 +0000
commitee69e71fff726ee54c62850b81f4f275b8f3283c (patch)
treee0aa76624413dfe82816d7e453a2c6baa354e89b /app-emacs/htmlize
parentInclude CATEGORY and PN in call to has_version else we'll never get a match. (diff)
downloadgentoo-2-ee69e71fff726ee54c62850b81f4f275b8f3283c.tar.gz
gentoo-2-ee69e71fff726ee54c62850b81f4f275b8f3283c.tar.bz2
gentoo-2-ee69e71fff726ee54c62850b81f4f275b8f3283c.zip
Use autoload mechanism in site-init file.
(Portage version: 2.1.2.5)
Diffstat (limited to 'app-emacs/htmlize')
-rw-r--r--app-emacs/htmlize/ChangeLog5
-rw-r--r--app-emacs/htmlize/files/50htmlize-gentoo.el11
2 files changed, 14 insertions, 2 deletions
diff --git a/app-emacs/htmlize/ChangeLog b/app-emacs/htmlize/ChangeLog
index 47d05420ff86..75a29787381f 100644
--- a/app-emacs/htmlize/ChangeLog
+++ b/app-emacs/htmlize/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/htmlize
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/ChangeLog,v 1.13 2007/04/06 20:21:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/ChangeLog,v 1.14 2007/05/03 19:47:05 ulm Exp $
+
+ 03 May 2007; Ulrich Mueller <ulm@gentoo.org> files/50htmlize-gentoo.el:
+ Use autoload mechanism in site-init file.
06 Apr 2007; Christian Faulhammer <opfer@gentoo.org> -htmlize-1.16.ebuild,
htmlize-1.34.ebuild:
diff --git a/app-emacs/htmlize/files/50htmlize-gentoo.el b/app-emacs/htmlize/files/50htmlize-gentoo.el
index ba92740d245d..16921e3be63f 100644
--- a/app-emacs/htmlize/files/50htmlize-gentoo.el
+++ b/app-emacs/htmlize/files/50htmlize-gentoo.el
@@ -2,4 +2,13 @@
;;; htmlize site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(require 'htmlize)
+(autoload 'htmlize-buffer "htmlize"
+ "Convert BUFFER to HTML, preserving colors and decorations." t)
+(autoload 'htmlize-region "htmlize"
+ "Convert the region to HTML, preserving colors and decorations." t)
+(autoload 'htmlize-file "htmlize"
+ "Load FILE, fontify it, convert it to HTML, and save the result." t)
+(autoload 'htmlize-many-files "htmlize"
+ "Convert FILES to HTML and save the corresponding HTML versions." t)
+(autoload 'htmlize-many-files-dired "htmlize"
+ "HTMLize dired-marked files." t)