summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/gnuserv
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/gnuserv')
-rw-r--r--app-emacs/gnuserv/ChangeLog11
-rw-r--r--app-emacs/gnuserv/files/50gnuserv-gentoo.el7
-rw-r--r--app-emacs/gnuserv/files/digest-gnuserv-3.12.41
-rw-r--r--app-emacs/gnuserv/gnuserv-3.12.4.ebuild50
4 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/gnuserv/ChangeLog b/app-emacs/gnuserv/ChangeLog
new file mode 100644
index 000000000000..93eece5e7bfa
--- /dev/null
+++ b/app-emacs/gnuserv/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/gnuserv
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*gnuserv-3.12.4 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ gnuserv-3.12.4.ebuild, files/50gnuserv-gentoo.el,
+ files/digest-gnuserv-3.12.4 :
+
+ Initial import.
diff --git a/app-emacs/gnuserv/files/50gnuserv-gentoo.el b/app-emacs/gnuserv/files/50gnuserv-gentoo.el
new file mode 100644
index 000000000000..d0b1f77b3b09
--- /dev/null
+++ b/app-emacs/gnuserv/files/50gnuserv-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; gnuserv site-lisp configuration
+
+(setq load-path (cons (concat "@SITELISP@") load-path))
+;; necessary for FSF GNU Emacs only
+(autoload 'gnuserv-start "gnuserv-compat"
+ "Allow this Emacs process to be a server for client processes." t)
diff --git a/app-emacs/gnuserv/files/digest-gnuserv-3.12.4 b/app-emacs/gnuserv/files/digest-gnuserv-3.12.4
new file mode 100644
index 000000000000..3e6f6de62cc8
--- /dev/null
+++ b/app-emacs/gnuserv/files/digest-gnuserv-3.12.4
@@ -0,0 +1 @@
+MD5 d0e8143cadf4b62edd3dd606c8327b8e gnuserv-3.12.4.tar.gz 87138
diff --git a/app-emacs/gnuserv/gnuserv-3.12.4.ebuild b/app-emacs/gnuserv/gnuserv-3.12.4.ebuild
new file mode 100644
index 000000000000..40efb2b14fae
--- /dev/null
+++ b/app-emacs/gnuserv/gnuserv-3.12.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv/gnuserv-3.12.4.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Gnuserv allows you to attach to an already running Emacs."
+HOMEPAGE="http://meltin.net/hacks/emacs/"
+SRC_URI="http://meltin.net/hacks/emacs/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50gnuserv-gentoo.el
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/share/man/man1
+ make prefix=${D}/usr \
+ man1dir=${D}/usr/share/man/man1 \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ChangeLog COPYING INSTALL README README.orig
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}