summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-08-25 17:02:55 +0000
committerUlrich Müller <ulm@gentoo.org>2009-08-25 17:02:55 +0000
commit18f24d5be988cf4f2b45234a9868f2eef87bb9c9 (patch)
treec706cda0c376f863b70ea229ca1c7347d4277994 /app-emacs/gentoo-syntax
parentRemove old version. (diff)
downloadgentoo-2-18f24d5be988cf4f2b45234a9868f2eef87bb9c9.tar.gz
gentoo-2-18f24d5be988cf4f2b45234a9868f2eef87bb9c9.tar.bz2
gentoo-2-18f24d5be988cf4f2b45234a9868f2eef87bb9c9.zip
Assign PORTDIR in site-init file.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs/gentoo-syntax')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog7
-rw-r--r--app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.12.el9
-rw-r--r--app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el5
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild4
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild10
5 files changed, 26 insertions, 9 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index 465e0684f879..80b9fcd076d7 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.44 2009/08/25 13:39:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.45 2009/08/25 17:02:55 ulm Exp $
+
+ 25 Aug 2009; Ulrich Mueller <ulm@gentoo.org> gentoo-syntax-1.12.ebuild,
+ +files/50gentoo-syntax-gentoo-1.12.el, files/50gentoo-syntax-gentoo.el,
+ gentoo-syntax-9999.ebuild:
+ Assign PORTDIR in site-init file.
25 Aug 2009; Christian Faulhammer <fauli@gentoo.org>
gentoo-syntax-9999.ebuild:
diff --git a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.12.el b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.12.el
new file mode 100644
index 000000000000..4c4f2739c91d
--- /dev/null
+++ b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.12.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "gentoo-syntax"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'eselect-mode "gentoo-syntax" "Major mode for .eselect files." t)
+
+(add-to-list 'auto-mode-alist '("\\.\\(ebuild\\|eclass\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)
diff --git a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
index 6c5f0d536d79..80ce285a9bde 100644
--- a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
+++ b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; gentoo-syntax site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'ebuild-mode "gentoo-syntax"
"Major mode for Portage .ebuild and .eclass files." t)
@@ -10,3 +7,5 @@
(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)
+
+(setq ebuild-mode-portdir "@PORTDIR@")
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild
index 88d64c1c825f..99d19f825d0a 100644
--- a/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild,v 1.6 2009/07/16 17:42:15 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.12.ebuild,v 1.7 2009/08/25 17:02:55 ulm Exp $
inherit elisp
@@ -14,7 +14,7 @@ KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE=""
DOCS="ChangeLog"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
pkg_postinst() {
elisp-site-regen
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild
index c9b6db3cfad6..abfdd9986833 100644
--- a/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild,v 1.7 2009/08/25 13:39:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild,v 1.8 2009/08/25 17:02:55 ulm Exp $
inherit elisp subversion
@@ -23,8 +23,12 @@ src_compile() {
}
src_install() {
- elisp_src_install
- doinfo gentoo-syntax.info
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
}
pkg_postinst() {