summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-13 14:49:07 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-13 14:49:07 +0000
commit75eeda9ef69a2c181f3d438f2f28130fabc287b6 (patch)
tree07d53d6926473de8a1385d6da28d4851001d5e40 /app-emacs/flim
parentkeyworded ~arch for sparc, bug 291197 (diff)
downloadgentoo-2-75eeda9ef69a2c181f3d438f2f28130fabc287b6.tar.gz
gentoo-2-75eeda9ef69a2c181f3d438f2f28130fabc287b6.tar.bz2
gentoo-2-75eeda9ef69a2c181f3d438f2f28130fabc287b6.zip
Fix unibyte/multibyte issues with Emacs 23, bug 292449.
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'app-emacs/flim')
-rw-r--r--app-emacs/flim/ChangeLog11
-rw-r--r--app-emacs/flim/files/60flim-gentoo.el3
-rw-r--r--app-emacs/flim/files/flim-1.14.9-mel-q-ccl.patch31
-rw-r--r--app-emacs/flim/flim-1.14.9-r1.ebuild38
4 files changed, 78 insertions, 5 deletions
diff --git a/app-emacs/flim/ChangeLog b/app-emacs/flim/ChangeLog
index f2d2e7c29699..090479b4da53 100644
--- a/app-emacs/flim/ChangeLog
+++ b/app-emacs/flim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/flim
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/ChangeLog,v 1.38 2009/07/20 21:30:43 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/ChangeLog,v 1.39 2009/11/13 14:49:07 ulm Exp $
+
+*flim-1.14.9-r1 (13 Nov 2009)
+
+ 13 Nov 2009; Ulrich Mueller <ulm@gentoo.org> +flim-1.14.9-r1.ebuild,
+ +files/flim-1.14.9-mel-q-ccl.patch:
+ Fix unibyte/multibyte issues with Emacs 23. Thanks to Jan Seeger
+ <jan.seeger@gmail.com> in bug 292449.
20 Jul 2009; Christian Faulhammer <fauli@gentoo.org> -flim-1.14.8.ebuild:
clean up
@@ -130,7 +137,7 @@
*flim-1.14.4 (31 Oct 2002)
31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
- flim-1.14.4.ebuild, files/60flim-gentoo.el,
+ flim-1.14.4.ebuild, files/60flim-gentoo.el,
files/digest-flim-1.14.4 :
Initial import.
diff --git a/app-emacs/flim/files/60flim-gentoo.el b/app-emacs/flim/files/60flim-gentoo.el
index 8c9af98c5ec1..431f7e90ae73 100644
--- a/app-emacs/flim/files/60flim-gentoo.el
+++ b/app-emacs/flim/files/60flim-gentoo.el
@@ -1,4 +1 @@
-
-;;; FLIM site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/flim/files/flim-1.14.9-mel-q-ccl.patch b/app-emacs/flim/files/flim-1.14.9-mel-q-ccl.patch
new file mode 100644
index 000000000000..35f645052284
--- /dev/null
+++ b/app-emacs/flim/files/flim-1.14.9-mel-q-ccl.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/292449
+
+--- flim-1.14.9-orig/mel-q-ccl.el 2006-06-12 17:10:02.000000000 +0200
++++ flim-1.14.9/mel-q-ccl.el 2009-11-13 15:38:28.000000000 +0100
+@@ -893,7 +893,13 @@
+ (defun quoted-printable-ccl-encode-region (start end)
+ "Encode the region from START to END with quoted-printable encoding."
+ (interactive "*r")
+- (decode-coding-region start end 'mel-ccl-quoted-printable-lf-lf-rev))
++ (save-excursion
++ (goto-char start)
++ (insert (prog1
++ (decode-coding-string
++ (string-as-unibyte (buffer-substring start end))
++ 'mel-ccl-quoted-printable-lf-lf-rev)
++ (delete-region start end)))))
+
+ (defun quoted-printable-ccl-insert-encoded-file (filename)
+ "Encode contents of the file named as FILENAME, and insert it."
+@@ -932,7 +938,10 @@
+ (defun quoted-printable-ccl-write-decoded-region (start end filename)
+ "Decode quoted-printable encoded current region and write out to FILENAME."
+ (interactive "*r\nFWrite decoded region to file: ")
+- (let ((coding-system-for-write 'mel-ccl-quoted-printable-lf-lf-rev)
++ (let ((coding-system-for-write
++ (if (coding-system-p 'mel-ccl-quoted-printable-lf-lf-rev-unix)
++ 'mel-ccl-quoted-printable-lf-lf-rev-unix
++ 'mel-ccl-quoted-printable-lf-lf-rev))
+ jka-compr-compression-info-list jam-zcat-filename-list)
+ (write-region start end filename)))
+
diff --git a/app-emacs/flim/flim-1.14.9-r1.ebuild b/app-emacs/flim/flim-1.14.9-r1.ebuild
new file mode 100644
index 000000000000..0646ccb52a11
--- /dev/null
+++ b/app-emacs/flim/flim-1.14.9-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.9-r1.ebuild,v 1.1 2009/11/13 14:49:07 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="A library to provide basic features about message representation or encoding"
+HOMEPAGE="http://cvs.m17n.org/elisp/FLIM/"
+SRC_URI="http://www.kanji.zinbun.kyoto-u.ac.jp/~tomo/lemi/dist/flim/${P%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-emacs/apel-10.3"
+RDEPEND="${DEPEND}
+ !app-emacs/limit"
+
+ELISP_PATCHES="${P}-mel-q-ccl.patch"
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ emake PREFIX="${D}/usr" \
+ LISPDIR="${D}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${D}/${SITELISP}" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" \
+ LISPDIR="${D}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${D}/${SITELISP}" install \
+ || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ dodoc FLIM-API.en NEWS VERSION README* ChangeLog || die "dodoc failed"
+}