summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-01-30 11:59:33 +0000
committerUlrich Müller <ulm@gentoo.org>2011-01-30 11:59:33 +0000
commite732d2c31cca1dc42e3ea4c4d1f62c38de9159b3 (patch)
tree42a9d3ad8ad777909b191fecefed4cc77190ff9e /app-emacs/ess
parentx86 stable wrt bug #353028 (diff)
downloadgentoo-2-e732d2c31cca1dc42e3ea4c4d1f62c38de9159b3.tar.gz
gentoo-2-e732d2c31cca1dc42e3ea4c4d1f62c38de9159b3.tar.bz2
gentoo-2-e732d2c31cca1dc42e3ea4c4d1f62c38de9159b3.zip
Don't call prepalldocs, it is no longer needed with EAPI 4.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/ess')
-rw-r--r--app-emacs/ess/ChangeLog7
-rw-r--r--app-emacs/ess/ess-5.12-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emacs/ess/ChangeLog b/app-emacs/ess/ChangeLog
index e0de93a9f523..fdb762a2761b 100644
--- a/app-emacs/ess/ChangeLog
+++ b/app-emacs/ess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ess
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.73 2011/01/08 00:52:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.74 2011/01/30 11:59:33 ulm Exp $
+
+*ess-5.12-r1 (30 Jan 2011)
+
+ 30 Jan 2011; Ulrich Mueller <ulm@gentoo.org> +ess-5.12-r1.ebuild:
+ Don't call prepalldocs, it is no longer needed with EAPI 4.
08 Jan 2011; Brent Baude <ranger@gentoo.org> ess-5.12.ebuild:
Marking ess-5.12 ppc for bug 348198
diff --git a/app-emacs/ess/ess-5.12-r1.ebuild b/app-emacs/ess/ess-5.12-r1.ebuild
new file mode 100644
index 000000000000..241f97fb5adc
--- /dev/null
+++ b/app-emacs/ess/ess-5.12-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.12-r1.ebuild,v 1.1 2011/01/30 11:59:33 ulm Exp $
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+# This is NOT redundant, elisp.eclass redefines src_compile.
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/ess/lisp/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc lisp/ChangeLog ChangeLog-lisp
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please see /usr/share/doc/${PF} for the complete documentation."
+ elog "Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+}