summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-04-03 20:54:17 +0000
committerUlrich Müller <ulm@gentoo.org>2013-04-03 20:54:17 +0000
commitfbab5c0aaedf87195fb2e59b9462710c234ef979 (patch)
tree4fdacc065fba5d642debda735190fa3d102f4076 /app-emacs/emms
parentfix whitespace (diff)
downloadgentoo-2-fbab5c0aaedf87195fb2e59b9462710c234ef979.tar.gz
gentoo-2-fbab5c0aaedf87195fb2e59b9462710c234ef979.tar.bz2
gentoo-2-fbab5c0aaedf87195fb2e59b9462710c234ef979.zip
Fix build failure with texinfo-5.1, bug 464308. Update EAPI. Specify LICENSE more precisely. Remove old.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/emms')
-rw-r--r--app-emacs/emms/ChangeLog10
-rw-r--r--app-emacs/emms/emms-3.0-r1.ebuild23
-rw-r--r--app-emacs/emms/emms-3.0.ebuild47
-rw-r--r--app-emacs/emms/files/2.0-taglib-Makefile-gentoo.patch12
-rw-r--r--app-emacs/emms/files/emms-3.0-texinfo-5.patch17
5 files changed, 37 insertions, 72 deletions
diff --git a/app-emacs/emms/ChangeLog b/app-emacs/emms/ChangeLog
index 4117a102416e..06963ec969df 100644
--- a/app-emacs/emms/ChangeLog
+++ b/app-emacs/emms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/emms
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/ChangeLog,v 1.14 2010/08/09 20:19:30 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/ChangeLog,v 1.15 2013/04/03 20:54:16 ulm Exp $
+
+ 03 Apr 2013; Ulrich Müller <ulm@gentoo.org>
+ -files/2.0-taglib-Makefile-gentoo.patch, -emms-3.0.ebuild,
+ emms-3.0-r1.ebuild, +files/emms-3.0-texinfo-5.patch:
+ Fix build failure with texinfo-5.1, bug 464308. Update EAPI. Specify LICENSE
+ more precisely. Remove old.
*emms-3.0-r1 (09 Aug 2010)
diff --git a/app-emacs/emms/emms-3.0-r1.ebuild b/app-emacs/emms/emms-3.0-r1.ebuild
index 6b506c76f1c1..16d076203a84 100644
--- a/app-emacs/emms/emms-3.0-r1.ebuild
+++ b/app-emacs/emms/emms-3.0-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/emms-3.0-r1.ebuild,v 1.1 2010/08/09 20:19:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/emms-3.0-r1.ebuild,v 1.2 2013/04/03 20:54:16 ulm Exp $
+EAPI=5
NEED_EMACS=22
inherit elisp toolchain-funcs
@@ -11,10 +12,9 @@ HOMEPAGE="http://www.gnu.org/software/emms/
http://www.emacswiki.org/cgi-bin/wiki/EMMS"
SRC_URI="http://www.gnu.org/software/emms/download/${P}.tar.gz"
-LICENSE="GPL-3 FDL-1.1"
+LICENSE="GPL-3+ FDL-1.1+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
DEPEND="media-libs/taglib"
RDEPEND="${DEPEND}"
@@ -23,19 +23,20 @@ RDEPEND="${DEPEND}"
# possibilities are so broad that we refrain from setting anything explicitly
# in DEPEND/RDEPEND.
-ELISP_PATCHES="${P}-Makefile.patch"
+ELISP_PATCHES="${P}-Makefile.patch
+ ${P}-texinfo-5.patch"
SITEFILE="50${PN}-gentoo.el"
src_compile() {
emake CC="$(tc-getCC)" \
EMACS=emacs \
- all emms-print-metadata || die
+ all emms-print-metadata
}
src_install() {
- elisp-install ${PN} *.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- doinfo *.info* || die
- dobin *-wrapper emms-print-metadata || die
- dodoc AUTHORS ChangeLog FAQ NEWS README RELEASE || die
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo *.info*
+ dobin *-wrapper emms-print-metadata
+ dodoc AUTHORS ChangeLog FAQ NEWS README RELEASE
}
diff --git a/app-emacs/emms/emms-3.0.ebuild b/app-emacs/emms/emms-3.0.ebuild
deleted file mode 100644
index e05381efab7b..000000000000
--- a/app-emacs/emms/emms-3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/emms-3.0.ebuild,v 1.3 2009/05/05 07:55:53 fauli Exp $
-
-NEED_EMACS=22
-
-inherit elisp toolchain-funcs eutils
-
-DESCRIPTION="The Emacs Multimedia System"
-HOMEPAGE="http://www.gnu.org/software/emms/
- http://www.emacswiki.org/cgi-bin/wiki/EMMS"
-SRC_URI="http://www.gnu.org/software/emms/download/${P}.tar.gz"
-
-LICENSE="GPL-3 FDL-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-IUSE=""
-
-DEPEND="media-libs/taglib"
-RDEPEND="${DEPEND}"
-
-# EMMS can use almost anything for playing media files therefore the dependency
-# possibilities are so broad that we refrain from setting anything explicitly
-# in DEPEND/RDEPEND.
-
-SITEFILE=50${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/2.0-taglib-Makefile-gentoo.patch"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- EMACS=emacs \
- all emms-print-metadata \
- || die "emake failed"
-}
-
-src_install() {
- elisp-install ${PN} *.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- doinfo *.info*
- dobin *-wrapper emms-print-metadata
- dodoc AUTHORS ChangeLog FAQ NEWS README RELEASE || die "dodoc failed"
-}
diff --git a/app-emacs/emms/files/2.0-taglib-Makefile-gentoo.patch b/app-emacs/emms/files/2.0-taglib-Makefile-gentoo.patch
deleted file mode 100644
index 519713f29acb..000000000000
--- a/app-emacs/emms/files/2.0-taglib-Makefile-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur emms-2.0.orig/Makefile emms-2.0/Makefile
---- emms-2.0.orig/Makefile 2006-04-29 14:28:28.000000000 -0500
-+++ emms-2.0/Makefile 2006-05-14 23:03:58.000000000 -0500
-@@ -41,7 +41,7 @@
- makeinfo --html --no-split $<
-
- emms-print-metadata: emms-print-metadata.c
-- $(CC) -o $@ $< -I/usr/include/taglib -L/usr/lib -ltag_c
-+ $(CC) -o $@ $< `taglib-config --libs --cflags` -ltag_c
-
- install:
- test -d $(SITELISP) || mkdir -p $(SITELISP)
diff --git a/app-emacs/emms/files/emms-3.0-texinfo-5.patch b/app-emacs/emms/files/emms-3.0-texinfo-5.patch
new file mode 100644
index 000000000000..10ee2ad57524
--- /dev/null
+++ b/app-emacs/emms/files/emms-3.0-texinfo-5.patch
@@ -0,0 +1,17 @@
+--- emms-3.0-orig/gpl.texi
++++ emms-3.0/gpl.texi
+@@ -659,6 +659,8 @@
+ Program, unless a warranty or assumption of liability accompanies a
+ copy of the Program in return for a fee.
+
++@end enumerate
++
+ @iftex
+ @heading END OF TERMS AND CONDITIONS
+ @end iftex
+@@ -721,5 +723,3 @@
+ applications with the library. If this is what you want to do, use
+ the GNU Lesser General Public License instead of this License. But
+ first, please read @url{http://www.gnu.org/philosophy/why-not-lgpl.html}.
+-
+-@end enumerate