summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-02-01 22:06:04 +0000
committerUlrich Müller <ulm@gentoo.org>2010-02-01 22:06:04 +0000
commitdccfb9338e48b147b492f8606876b95d2912ba1a (patch)
tree02937e3c8f35b35170664bcfcc4b978d2898a2b8 /app-emacs/elib
parentstable x86 (diff)
downloadgentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.tar.gz
gentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.tar.bz2
gentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs/elib')
-rw-r--r--app-emacs/elib/ChangeLog9
-rw-r--r--app-emacs/elib/elib-1.0-r1.ebuild36
-rw-r--r--app-emacs/elib/files/50elib-gentoo.el3
3 files changed, 43 insertions, 5 deletions
diff --git a/app-emacs/elib/ChangeLog b/app-emacs/elib/ChangeLog
index 9a142e235b13..a98f93efd93a 100644
--- a/app-emacs/elib/ChangeLog
+++ b/app-emacs/elib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/elib
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/elib/ChangeLog,v 1.12 2008/01/25 12:10:09 opfer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/elib/ChangeLog,v 1.13 2010/02/01 22:06:03 ulm Exp $
+
+*elib-1.0-r1 (01 Feb 2010)
+
+ 01 Feb 2010; Ulrich Mueller <ulm@gentoo.org> +elib-1.0-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
25 Jan 2008; Christian Faulhammer <opfer@gentoo.org> elib-1.0.ebuild:
correct HOMEPAGE
diff --git a/app-emacs/elib/elib-1.0-r1.ebuild b/app-emacs/elib/elib-1.0-r1.ebuild
new file mode 100644
index 000000000000..1f7adca3594a
--- /dev/null
+++ b/app-emacs/elib/elib-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/elib/elib-1.0-r1.ebuild,v 1.1 2010/02/01 22:06:03 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="The Emacs Lisp Library"
+HOMEPAGE="http://jdee.sourceforge.net"
+SRC_URI="http://jdee.sunsite.dk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i 's:--infodir:--info-dir:g' Makefile || die
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir "${SITELISP}/elib"
+ dodir /usr/share/info
+ emake prefix="${ED}/usr" infodir="${ED}/usr/share/info" install \
+ || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog NEWS README TODO || die "dodoc failed"
+}
diff --git a/app-emacs/elib/files/50elib-gentoo.el b/app-emacs/elib/files/50elib-gentoo.el
index cee12ac384e9..431f7e90ae73 100644
--- a/app-emacs/elib/files/50elib-gentoo.el
+++ b/app-emacs/elib/files/50elib-gentoo.el
@@ -1,4 +1 @@
-
-;;; elib site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")