summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-04-02 06:21:15 +0000
committerMamoru Komachi <usata@gentoo.org>2005-04-02 06:21:15 +0000
commita78f504e347a0d9ebb6343501f3a6c3fda57203b (patch)
tree90f7c1cba2dc2a04ba4558566534656ae78bba66 /app-emacs/auctex/auctex-11.55.ebuild
parentRemoving april fools joke. (diff)
downloadgentoo-2-a78f504e347a0d9ebb6343501f3a6c3fda57203b.tar.gz
gentoo-2-a78f504e347a0d9ebb6343501f3a6c3fda57203b.tar.bz2
gentoo-2-a78f504e347a0d9ebb6343501f3a6c3fda57203b.zip
Version bumped. This closes bug #84273.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emacs/auctex/auctex-11.55.ebuild')
-rw-r--r--app-emacs/auctex/auctex-11.55.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/auctex/auctex-11.55.ebuild b/app-emacs/auctex/auctex-11.55.ebuild
new file mode 100644
index 000000000000..7717be787826
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.55.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.55.ebuild,v 1.1 2005/04/02 06:21:15 usata Exp $
+
+inherit elisp
+
+DESCRIPTION="AUCTeX is an extensible package that supports writing and formatting TeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/tetex"
+
+src_compile() {
+ econf --with-auto-dir=${D}/var/lib/auctex \
+ --with-lispdir=${D}/usr/share/emacs/site-lisp \
+ --with-tex-input-dirs="/usr/share/texmf/tex/;/usr/share/texmf/bibtex/bst/" || die "econf failed"
+ emake || die
+
+ # bug #72637
+ elisp-comp *.el || die
+}
+
+src_install() {
+ einstall || die
+ elisp-install ${PN} bib-cite.el* tex-jp.el* || die
+ dosed ${SITELISP}/tex-site.el || die
+ elisp-site-file-install ${FILESDIR}/50auctex-gentoo.el
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}