summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-04-20 15:30:57 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-04-20 15:30:57 +0000
commit6ea389b197a376d3b7abd5022e475c5ebbaaf170 (patch)
tree728c2a8fe3b994ac439d34f7a91cafb205014823 /app-emacs/aspectj4emacs
parentVersion bumped. Closes 41907 (Manifest recommit) (diff)
downloadgentoo-2-6ea389b197a376d3b7abd5022e475c5ebbaaf170.tar.gz
gentoo-2-6ea389b197a376d3b7abd5022e475c5ebbaaf170.tar.bz2
gentoo-2-6ea389b197a376d3b7abd5022e475c5ebbaaf170.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/aspectj4emacs')
-rw-r--r--app-emacs/aspectj4emacs/ChangeLog12
-rw-r--r--app-emacs/aspectj4emacs/Manifest5
-rw-r--r--app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild47
-rw-r--r--app-emacs/aspectj4emacs/files/80aspectj4emacs-gentoo.el24
-rw-r--r--app-emacs/aspectj4emacs/files/aspectj4emacs-1.1_beta2-compile-log-gentoo.patch74
-rw-r--r--app-emacs/aspectj4emacs/files/digest-aspectj4emacs-1.1_beta21
-rw-r--r--app-emacs/aspectj4emacs/metadata.xml6
7 files changed, 169 insertions, 0 deletions
diff --git a/app-emacs/aspectj4emacs/ChangeLog b/app-emacs/aspectj4emacs/ChangeLog
new file mode 100644
index 000000000000..c9230e5ef56b
--- /dev/null
+++ b/app-emacs/aspectj4emacs/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-emacs/aspectj4emacs
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/aspectj4emacs/ChangeLog,v 1.1 2004/04/20 15:30:57 mkennedy Exp $
+
+*aspectj4emacs-1.1_beta2 (20 Apr 2004)
+
+ 20 Apr 2004; <mkennedy@gentoo.org> +metadata.xml,
+ +files/80aspectj4emacs-gentoo.el,
+ +files/aspectj4emacs-1.1_beta2-compile-log-gentoo.patch,
+ +aspectj4emacs-1.1_beta2.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/aspectj4emacs/Manifest b/app-emacs/aspectj4emacs/Manifest
new file mode 100644
index 000000000000..85d82738d812
--- /dev/null
+++ b/app-emacs/aspectj4emacs/Manifest
@@ -0,0 +1,5 @@
+MD5 b33c6eeb5218b6db542781be96e08ece aspectj4emacs-1.1_beta2.ebuild 842
+MD5 ec147919b4449874204c29346a077b0e aspectj4emacs-1.1_beta2.ebuild~ 1128
+MD5 8c144cf6053d420b8e0bb2c46d8cca80 metadata.xml 176
+MD5 213e5ec3ba54c69db9137bc3a0eda0d9 files/digest-aspectj4emacs-1.1_beta2 70
+MD5 7158a0f444921d301f3048ce0c65435c files/80aspectj4emacs-gentoo.el 223
diff --git a/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild b/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild
new file mode 100644
index 000000000000..c8dddd5f1d85
--- /dev/null
+++ b/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild,v 1.1 2004/04/20 15:30:57 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+MYPV="1.1b2"
+
+DESCRIPTION="AspectJ support for GNU Emacs java-mode and JDEE"
+HOMEPAGE="http://aspectj4emacs.sourceforge.net/"
+SRC_URI="http://aspectj4emacs.sourceforge.net/AspectJForEmacs-${MYPV}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ app-emacs/jde
+ =dev-java/aspectj-1.1*"
+
+S="${WORKDIR}/AspectJForEmacs-${MYPV}"
+
+SITEFILE=80aspectj4emacs-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PF}-compile-log-gentoo.patch
+ cd ${S}
+ cp */*.el .
+ sed -i "s,@build.version.short@,${PV},g" *.el
+}
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp_src_install
+ for subdir in ajdee aspectj-mode; do
+ insinto /usr/share/doc/${PF}/${subdir}
+ doins `find ${subdir} -type f ! -name \*.el`
+ dosym /usr/share/doc/${PF}/html/${subdir}.html \
+ /usr/share/emacs/site-lisp/${PN}/${subdir}.html
+ done
+ dohtml *.html *.gif
+}
diff --git a/app-emacs/aspectj4emacs/files/80aspectj4emacs-gentoo.el b/app-emacs/aspectj4emacs/files/80aspectj4emacs-gentoo.el
new file mode 100644
index 000000000000..be952dcee6b0
--- /dev/null
+++ b/app-emacs/aspectj4emacs/files/80aspectj4emacs-gentoo.el
@@ -0,0 +1,24 @@
+
+;;; aspectj4emacs site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'aspectj-mode)
+(require 'ajdee)
+
+;;; JDEE/speedbar settings to make it behave better for AspectJ. You might
+;;; want to do this via a prj.el file (see sample.prj) if you program in
+;;; vanilla Java as well. The sample.prj has settings for spacewar, a more
+;;; complicated project.
+(custom-set-variables
+ '(jde-compiler '("ajc" "ajc")) ; ajc is AspectJ's compiler
+ '(jde-javadoc-command-path "ajdoc"))
+
+;;; The following are settings recommened by AspectJ for Emacs' author
+
+(custom-set-variables
+ ;; Widen the speedbar to show more of AJ's longer tag names.
+ '(speedbar-frame-parameters
+ (quote ((minibuffer) (width . 30) (border-width . 0) (menu-bar-lines . 0)
+ (unsplittable . t))))
+ ;; Don't let speedbar split into submenus smaller than 40 items
+ '(speedbar-tag-split-minimum-length 40))
diff --git a/app-emacs/aspectj4emacs/files/aspectj4emacs-1.1_beta2-compile-log-gentoo.patch b/app-emacs/aspectj4emacs/files/aspectj4emacs-1.1_beta2-compile-log-gentoo.patch
new file mode 100644
index 000000000000..f72b8be9569b
--- /dev/null
+++ b/app-emacs/aspectj4emacs/files/aspectj4emacs-1.1_beta2-compile-log-gentoo.patch
@@ -0,0 +1,74 @@
+diff -ur /home/mkennedy/tmp/AspectJForEmacs-1.1b2.original/ /home/mkennedy/tmp/AspectJForEmacs-1.1b2/
+Only in /home/mkennedy/tmp/AspectJForEmacs-1.1b2/ajdee: ajdee.elc
+Only in /home/mkennedy/tmp/AspectJForEmacs-1.1b2/ajdee: semantic.cache
+diff -ur /home/mkennedy/tmp/AspectJForEmacs-1.1b2.original/aspectj-mode/aspectj-mode.el /home/mkennedy/tmp/AspectJForEmacs-1.1b2/aspectj-mode/aspectj-mode.el
+--- /home/mkennedy/tmp/AspectJForEmacs-1.1b2.original/aspectj-mode/aspectj-mode.el 2002-12-18 15:31:02.000000000 -0600
++++ /home/mkennedy/tmp/AspectJForEmacs-1.1b2/aspectj-mode/aspectj-mode.el 2004-04-19 23:13:40.847760384 -0500
+@@ -2135,6 +2135,30 @@
+ ;;;
+ ;;; Declarations data cache management.
+ ;;;
++;;;
++;;; The time returned by file attributes are two 16-bit ints in hi-order
++;;; low-order bit order, but we really don't care. Since time moves
++;;; forward, we only care if the timestamp changes.
++;;;
++(defun aspectj-file-timestamp (fn) (nth 5 (file-attributes fn)))
++
++;;; Non-nil so as to not be confused with uninitialized timestamps.
++(defconst aspectj-notexist-timestamp -1)
++
++(defun aspectj-declaration-file (fn)
++ (concat (file-name-sans-extension fn) ".ajesym")) ; WGG/WARNING/TEST
++
++(defvar aspectj-buffers-declarations nil)
++(make-variable-buffer-local 'aspectj-buffers-declarations)
++
++(defvar aspectj-declarations-timestamp nil)
++(make-variable-buffer-local 'aspectj-declarations-timestamp)
++
++(defun aspectj-declarations-file-timestamp (fn)
++ (let ((declarations-file (aspectj-declaration-file fn)))
++ (if (file-exists-p declarations-file)
++ (aspectj-file-timestamp declarations-file)
++ aspectj-notexist-timestamp)))
+
+ ;;;
+ ;;; Cached version of aspectj-fetch-declarations.
+@@ -2162,31 +2186,6 @@
+ (setq ad-return-value (copy-tree ad-return-value)))) ; !!! WARNING WGG
+
+ ;;;
+-;;; The time returned by file attributes are two 16-bit ints in hi-order
+-;;; low-order bit order, but we really don't care. Since time moves
+-;;; forward, we only care if the timestamp changes.
+-;;;
+-(defun aspectj-file-timestamp (fn) (nth 5 (file-attributes fn)))
+-
+-;;; Non-nil so as to not be confused with uninitialized timestamps.
+-(defconst aspectj-notexist-timestamp -1)
+-
+-(defun aspectj-declaration-file (fn)
+- (concat (file-name-sans-extension fn) ".ajesym")) ; WGG/WARNING/TEST
+-
+-(defvar aspectj-buffers-declarations nil)
+-(make-variable-buffer-local 'aspectj-buffers-declarations)
+-
+-(defvar aspectj-declarations-timestamp nil)
+-(make-variable-buffer-local 'aspectj-declarations-timestamp)
+-
+-(defun aspectj-declarations-file-timestamp (fn)
+- (let ((declarations-file (aspectj-declaration-file fn)))
+- (if (file-exists-p declarations-file)
+- (aspectj-file-timestamp declarations-file)
+- aspectj-notexist-timestamp)))
+-
+-;;;
+ ;;; For what we're doing with this, maybe we could just check the timestamp,
+ ;;; but this is more inclusive if this check is done when aj-mode is on,
+ ;;; but the declarations file isn't loaded *yet*.
+Only in /home/mkennedy/tmp/AspectJForEmacs-1.1b2/aspectj-mode: aspectj-mode.elc
+Only in /home/mkennedy/tmp/AspectJForEmacs-1.1b2/aspectj-mode: aspectj-mode.el~
+Only in /home/mkennedy/tmp/AspectJForEmacs-1.1b2/aspectj-mode: semantic.cache
+
+Diff finished. Mon Apr 19 23:14:39 2004
diff --git a/app-emacs/aspectj4emacs/files/digest-aspectj4emacs-1.1_beta2 b/app-emacs/aspectj4emacs/files/digest-aspectj4emacs-1.1_beta2
new file mode 100644
index 000000000000..e69b4825a550
--- /dev/null
+++ b/app-emacs/aspectj4emacs/files/digest-aspectj4emacs-1.1_beta2
@@ -0,0 +1 @@
+MD5 3bdbf0a9819a29a2b4003b5fd8d31fba AspectJForEmacs-1.1b2.zip 122650
diff --git a/app-emacs/aspectj4emacs/metadata.xml b/app-emacs/aspectj4emacs/metadata.xml
new file mode 100644
index 000000000000..99df102501c5
--- /dev/null
+++ b/app-emacs/aspectj4emacs/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>java</herd>
+</pkgmetadata>