summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-15 19:39:22 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-15 19:39:22 +0000
commitfa374ac7020354845d7f29db3c9e816ff2859584 (patch)
treedce873c1423e5a0f3513f18e8898f9707cb91d80 /app-editors
parentImport Gentoo Prefix changes, convert to EAPI3, add keywords. bug 310991 (diff)
downloadgentoo-2-fa374ac7020354845d7f29db3c9e816ff2859584.tar.gz
gentoo-2-fa374ac7020354845d7f29db3c9e816ff2859584.tar.bz2
gentoo-2-fa374ac7020354845d7f29db3c9e816ff2859584.zip
Import Gentoo Prefix changes, convert to EAPI3, add keywords. bug 310991
(Portage version: 2.1.8.3/cvs/Linux armv7l)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog8
-rw-r--r--app-editors/vim/files/vim-7.1-interix-link.patch16
-rw-r--r--app-editors/vim/files/vim-7.1.285-darwin-x11link.patch11
-rw-r--r--app-editors/vim/files/vim-7.1.319-interix-cflags.patch23
-rw-r--r--app-editors/vim/vim-7.2.402.ebuild16
5 files changed, 70 insertions, 4 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 9a6a206cf45f..679b7b91f615 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.344 2010/03/17 22:00:36 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.345 2010/04/15 19:39:22 darkside Exp $
+
+ 15 Apr 2010; Jeremy Olexa <darkside@gentoo.org>
+ +files/vim-7.1.285-darwin-x11link.patch,
+ +files/vim-7.1.319-interix-cflags.patch,
+ +files/vim-7.1-interix-link.patch, vim-7.2.402.ebuild:
+ Import Gentoo Prefix changes, convert to EAPI3, add keywords. bug 310991
*vim-7.2.402 (17 Mar 2010)
diff --git a/app-editors/vim/files/vim-7.1-interix-link.patch b/app-editors/vim/files/vim-7.1-interix-link.patch
new file mode 100644
index 000000000000..da046665dfc5
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1-interix-link.patch
@@ -0,0 +1,16 @@
+Interix 3.5 does link fine with some libraries removed from the link
+line (who knows why), but executing vim failes with unresolved
+references to things like _dlclose, _iconv and such...
+
+diff -ru vim71.orig/src/link.sh vim71/src/link.sh
+--- vim71.orig/src/link.sh Wed Feb 27 15:29:29 2008
++++ vim71/src/link.sh Wed Feb 27 15:32:07 2008
+@@ -41,7 +41,7 @@
+ if sh link.cmd; then
+ touch auto/link.sed
+ cp link.cmd linkit.sh
+- for libname in SM ICE nsl dnet dnet_stub inet socket dir elf iconv Xt Xmu Xp Xpm X11 Xdmcp x w dl pthread thread readline m perl crypt attr; do
++ for libname in dummy; do
+ cont=yes
+ while test -n "$cont"; do
+ if grep "l$libname " linkit.sh >/dev/null; then
diff --git a/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch b/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch
new file mode 100644
index 000000000000..1cf00d6a8faa
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch
@@ -0,0 +1,11 @@
+--- src/configure.in
++++ src/configure.in
+@@ -2701,7 +2701,7 @@
+ AC_MSG_CHECKING(whether X_LOCALE needed)
+ AC_TRY_COMPILE([#include <X11/Xlocale.h>],,
+ AC_TRY_LINK_FUNC([_Xsetlocale], [AC_MSG_RESULT(yes)
+- AC_DEFINE(X_LOCALE)], AC_MSG_RESULT(no)),
++ AC_DEFINE(X_LOCALE) ldflags_save="$ldflags_save -lX11"], AC_MSG_RESULT(no)),
+ AC_MSG_RESULT(no))
+ fi
+ CFLAGS=$cflags_save
diff --git a/app-editors/vim/files/vim-7.1.319-interix-cflags.patch b/app-editors/vim/files/vim-7.1.319-interix-cflags.patch
new file mode 100644
index 000000000000..630e0015ee0a
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1.319-interix-cflags.patch
@@ -0,0 +1,23 @@
+diff -ru vim71.orig/src/Makefile vim71/src/Makefile
+--- vim71.orig/src/Makefile 2008-07-16 08:29:55 +0200
++++ vim71/src/Makefile 2008-07-16 08:53:44 +0200
+@@ -1282,10 +1282,6 @@
+
+ ALL_CFLAGS = $(PRE_DEFS) $(CFLAGS) $(PROFILE_CFLAGS) $(POST_DEFS)
+
+-# Exclude $CFLAGS for osdef.sh, for Mac 10.4 some flags don't work together
+-# with "-E".
+-OSDEF_CFLAGS = $(PRE_DEFS) $(POST_DEFS)
+-
+ LINT_CFLAGS = -DLINT -I. $(PRE_DEFS) $(POST_DEFS) -Dinline= -D__extension__= -Dalloca=alloca
+
+ LINT_EXTRA = -DUSE_SNIFF -DHANGUL_INPUT -D"__attribute__(x)="
+@@ -2273,7 +2269,7 @@
+ $(PERLLIB)/ExtUtils/typemap if_perl.xs >> $@
+
+ auto/osdef.h: auto/config.h osdef.sh osdef1.h.in osdef2.h.in
+- CC="$(CC) $(OSDEF_CFLAGS)" srcdir=$(srcdir) sh $(srcdir)/osdef.sh
++ CC="$(CC) $(CFLAGS)" srcdir=$(srcdir) sh $(srcdir)/osdef.sh
+
+ QUOTESED = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
+ auto/pathdef.c: Makefile auto/config.mk
diff --git a/app-editors/vim/vim-7.2.402.ebuild b/app-editors/vim/vim-7.2.402.ebuild
index 5968c2b5c9af..3ae971b870fa 100644
--- a/app-editors/vim/vim-7.2.402.ebuild
+++ b/app-editors/vim/vim-7.2.402.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.2.402.ebuild,v 1.1 2010/03/17 22:00:36 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.2.402.ebuild,v 1.2 2010/04/15 19:39:22 darkside Exp $
-EAPI=2
+EAPI=3
inherit vim
VIM_VERSION="7.2"
@@ -15,5 +15,15 @@ SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
S="${WORKDIR}/vim${VIM_VERSION/.}"
DESCRIPTION="Vim, an improved vi-style text editor"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}