summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-02 17:47:03 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-02 17:47:03 +0000
commitf6f47f09aa097654b22f9cfa8510ce92b742f9d4 (patch)
tree9a0d45025923b01c803f6e5fd2d484eb91dfd90b /app-editors
parentAdded doc flag pulling app-doc/geant-docs package (diff)
downloadgentoo-2-f6f47f09aa097654b22f9cfa8510ce92b742f9d4.tar.gz
gentoo-2-f6f47f09aa097654b22f9cfa8510ce92b742f9d4.tar.bz2
gentoo-2-f6f47f09aa097654b22f9cfa8510ce92b742f9d4.zip
Version bump (bug #475474).
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hteditor/ChangeLog7
-rw-r--r--app-editors/hteditor/hteditor-2.0.22.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-editors/hteditor/ChangeLog b/app-editors/hteditor/ChangeLog
index 55e49bbb5129..cb297be1a2b3 100644
--- a/app-editors/hteditor/ChangeLog
+++ b/app-editors/hteditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/hteditor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.63 2013/02/14 22:04:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.64 2013/07/02 17:47:03 radhermit Exp $
+
+*hteditor-2.0.22 (02 Jul 2013)
+
+ 02 Jul 2013; Tim Harder <radhermit@gentoo.org> +hteditor-2.0.22.ebuild:
+ Version bump (bug #475474).
14 Feb 2013; Agostino Sarubbo <ago@gentoo.org> hteditor-2.0.21.ebuild:
Stable for ppc, wrt bug #457232
diff --git a/app-editors/hteditor/hteditor-2.0.22.ebuild b/app-editors/hteditor/hteditor-2.0.22.ebuild
new file mode 100644
index 000000000000..e022089727c1
--- /dev/null
+++ b/app-editors/hteditor/hteditor-2.0.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.0.22.ebuild,v 1.1 2013/07/02 17:47:03 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_P=${P/editor}
+
+DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
+HOMEPAGE="http://hte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ >=dev-libs/lzo-2"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable X x11-textmode) \
+ --enable-maintainermode
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ #For prefix
+ chmod u+x "${S}/install-sh"
+
+ default
+
+ dohtml doc/*.html
+ doinfo doc/*.info
+}