summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-12 21:06:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-12 21:06:35 +0000
commiteb3986c0f8512f95078494bd7fb057248f2614ae (patch)
treecb46f15ae22d872980e9f61d943341866e03c959 /app-editors
parentExtend multilib fixes wrt bug 407961 by Robin Johnson <robbat2@gentoo.org> (diff)
downloadgentoo-2-eb3986c0f8512f95078494bd7fb057248f2614ae.tar.gz
gentoo-2-eb3986c0f8512f95078494bd7fb057248f2614ae.tar.bz2
gentoo-2-eb3986c0f8512f95078494bd7fb057248f2614ae.zip
version bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qxmledit/ChangeLog7
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index 8cd66fd84365..34639b3038ba 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.21 2012/02/20 22:06:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.22 2012/03/12 21:06:35 hwoarang Exp $
+
+*qxmledit-0.8.0 (12 Mar 2012)
+
+ 12 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +qxmledit-0.8.0.ebuild:
+ version bump
*qxmledit-0.7.2 (20 Feb 2012)
diff --git a/app-editors/qxmledit/qxmledit-0.8.0.ebuild b/app-editors/qxmledit/qxmledit-0.8.0.ebuild
new file mode 100644
index 000000000000..abc06a4237c3
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.8.0.ebuild,v 1.1 2012/03/12 21:06:35 hwoarang Exp $
+
+EAPI=4
+
+inherit multilib qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-xmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README TODO"
+DOCSDIR="${WORKDIR}/${P}/"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/^INST_DOC_DIR/ s|/opt/${PN}|/usr/share/doc/${PF}|" src/QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix installation path
+ sed -i "/^INST_DIR/ s|/opt/${PN}|/usr/bin|" src/QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix widget library
+ sed -i "/^INST_DIR/ s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEditWidget.pro || die "failed to fix library installation path"
+ # fix translations
+ sed -i "/^INST_DATA_DIR/ s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro || \
+ die "failed to fix translations"
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}