summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-07-12 13:01:54 +0000
committerJim Ramsay <lack@gentoo.org>2012-07-12 13:01:54 +0000
commite80516c93967ed45ec33f6894ae257fc3c0090d2 (patch)
treec8d763e362cb753a79e9ae085812f7aac08f218c /app-editors
parentVersion bump: 7.3.600 is released (diff)
downloadgentoo-2-e80516c93967ed45ec33f6894ae257fc3c0090d2.tar.gz
gentoo-2-e80516c93967ed45ec33f6894ae257fc3c0090d2.tar.bz2
gentoo-2-e80516c93967ed45ec33f6894ae257fc3c0090d2.zip
Version bump: 7.3.600 is released
(Portage version: 2.1.11.2/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/gvim-7.3.600.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index b2a2525772e2..9ac503787eed 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.382 2012/06/27 14:20:56 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.383 2012/07/12 13:01:54 lack Exp $
+
+*gvim-7.3.600 (12 Jul 2012)
+
+ 12 Jul 2012; Jim Ramsay <jim_ramsay@gentoo.org> +gvim-7.3.600.ebuild:
+ Version bump: 7.3.600 is released
*gvim-7.3.566 (27 Jun 2012)
diff --git a/app-editors/gvim/gvim-7.3.600.ebuild b/app-editors/gvim/gvim-7.3.600.ebuild
new file mode 100644
index 000000000000..e8695d15bc20
--- /dev/null
+++ b/app-editors/gvim/gvim-7.3.600.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.3.600.ebuild,v 1.1 2012/07/12 13:01:54 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+}