summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 17:44:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 17:44:45 +0000
commite5690788c6dfec571c1037481346666796fd3237 (patch)
treee53bed7f7a64f403136a69af11d041b0b7886765 /app-editors
parentStable on alpha, bug #267209 (diff)
downloadgentoo-2-e5690788c6dfec571c1037481346666796fd3237.tar.gz
gentoo-2-e5690788c6dfec571c1037481346666796fd3237.tar.bz2
gentoo-2-e5690788c6dfec571c1037481346666796fd3237.zip
Bump to 4.3.0, fixes #180270
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xxe/ChangeLog9
-rw-r--r--app-editors/xxe/files/xxe.desktop2
-rw-r--r--app-editors/xxe/xxe-4.3.0.ebuild74
3 files changed, 82 insertions, 3 deletions
diff --git a/app-editors/xxe/ChangeLog b/app-editors/xxe/ChangeLog
index 7f93c3e989a5..68f41ea64a7b 100644
--- a/app-editors/xxe/ChangeLog
+++ b/app-editors/xxe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xxe
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.35 2008/04/21 16:39:51 phreak Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.36 2009/04/23 17:44:45 patrick Exp $
+
+*xxe-4.3.0 (23 Apr 2009)
+
+ 23 Apr 2009; Patrick Lauer <patrick@gentoo.org> +xxe-4.3.0.ebuild:
+ Bump to 4.3.0, fixes #180270
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-editors/xxe/files/xxe.desktop b/app-editors/xxe/files/xxe.desktop
index 8a20be94ccfa..89510bcc4d3b 100644
--- a/app-editors/xxe/files/xxe.desktop
+++ b/app-editors/xxe/files/xxe.desktop
@@ -7,4 +7,4 @@ Icon=/opt/xxe/bin/icon/xxe.gif
Name=XMLmind XML Editor
GenericName=XML Editor
Comment=XML file editor
-Categories=Application;Development
+Categories=Application;Development;
diff --git a/app-editors/xxe/xxe-4.3.0.ebuild b/app-editors/xxe/xxe-4.3.0.ebuild
new file mode 100644
index 000000000000..9c6824e07bb8
--- /dev/null
+++ b/app-editors/xxe/xxe-4.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/xxe-4.3.0.ebuild,v 1.1 2009/04/23 17:44:45 patrick Exp $
+
+MY_PV="${PV//./_}"
+MY_PV="${MY_PV/_p/p}"
+S="${WORKDIR}/${PN}-perso-${MY_PV}"
+
+ADDON_LIST="batik_imagetoolkit jimi_imagetoolkit dav_vdrive ftp_vdrive jeuclid_imagetoolkit mathml_config"
+ADDON_LIST="${ADDON_LIST} dita_dtd_config sample_customize_xxe sdocbook_config slides_config wxs_config"
+ADDON_LIST="${ADDON_LIST} xep_foprocessor fop1_foprocessor xfc_foprocessor xxe-devdocs xxe-docsrc xxe_config_pack"
+
+DESCRIPTION="The XMLmind XML Editor"
+
+for i in ${ADDON_LIST}
+do
+ SRC_URI_ADDON="${SRC_URI_ADDON} http://www.xmlmind.com/xmleditor/_download/${i}-${MY_PV}.zip"
+done
+
+SRC_URI="http://www.xmlmind.com/xmleditor/_download/${PN}-perso-${MY_PV}.tar.gz
+ doc? ( http://www.xmlmind.com/xmleditor/_download/${PN}-devdocs-${MY_PV}.tar.gz )
+ !minimal? ( ${SRC_URI_ADDON} )"
+
+HOMEPAGE="http://www.xmlmind.com/xmleditor/index.html"
+IUSE="doc minimal"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+RESTRICT="strip mirror"
+RDEPEND=">=virtual/jre-1.4.1"
+DEPEND=""
+INSTALLDIR=/opt/${PN}
+
+src_install() {
+ dodir ${INSTALLDIR}
+ cp -pPR "${S}"/* "${D}"/${INSTALLDIR}
+
+ dodir /etc/env.d
+ echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}" > "${D}"/etc/env.d/10xxe
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xxe.desktop
+
+ if ( use doc )
+ then
+ dodir /usr/share/doc/${PF}
+ cp -R "${WORKDIR}"/doc/* "${D}"/usr/share/doc/${PF}
+ mv "${D}"/${INSTALLDIR}/doc/* "${D}"/usr/share/doc/${PF}
+ fi
+ rm -rf "${D}"/${INSTALLDIR}/doc
+
+ if ( ! use minimal )
+ then
+ for i in ${ADDON_LIST}
+ do
+ cp -R "${WORKDIR}"/$i "${D}"/opt/xxe/addon
+ done
+ fi
+# apt_format
+}
+
+pkg_postinst() {
+ einfo
+ einfo "XXE has been installed in /opt/xxe, to include this"
+ einfo "in your path, run the following:"
+ eerror " /usr/sbin/env-update && source /etc/profile"
+ einfo
+ ewarn "If you need special/accented characters, you'll need to export LANG"
+ ewarn "to your locale. Example: export LANG=es_ES.ISO8859-1"
+ ewarn "See http://www.xmlmind.com/xmleditor/user_faq.html#linuxlocale"
+ einfo
+}