summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-01-23 16:53:41 +0000
committerUlrich Müller <ulm@gentoo.org>2009-01-23 16:53:41 +0000
commite115086b477b2275d2172c38e04b0f7688f0bea4 (patch)
treec3c59613b7f76249d9f25322ac58ea2ca73fd773 /app-editors
parentMarking php-5.2.8-r2 ppc64 for bug 249703 (diff)
downloadgentoo-2-e115086b477b2275d2172c38e04b0f7688f0bea4.tar.gz
gentoo-2-e115086b477b2275d2172c38e04b0f7688f0bea4.tar.bz2
gentoo-2-e115086b477b2275d2172c38e04b0f7688f0bea4.zip
Substitute the built_with_use check for libX11 by a USE dependency; therefore, change EAPI to 2.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog10
-rw-r--r--app-editors/emacs/emacs-18.59-r5.ebuild6
-rw-r--r--app-editors/emacs/emacs-18.59-r6.ebuild93
-rw-r--r--app-editors/emacs/metadata.xml2
4 files changed, 105 insertions, 6 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 69adc3c61272..1124588b3d96 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/emacs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.291 2008/12/24 11:18:38 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.292 2009/01/23 16:53:41 ulm Exp $
+
+*emacs-18.59-r6 (23 Jan 2009)
+
+ 23 Jan 2009; Ulrich Mueller <ulm@gentoo.org> +emacs-18.59-r6.ebuild:
+ Substitute the built_with_use check for libX11 by a USE dependency;
+ therefore, change EAPI to 2.
24 Dec 2008; Ulrich Mueller <ulm@gentoo.org>
-files/emacs-22.1-freebsd-sparc.patch,
diff --git a/app-editors/emacs/emacs-18.59-r5.ebuild b/app-editors/emacs/emacs-18.59-r5.ebuild
index 27d1c1b48119..91a4a2ac03fd 100644
--- a/app-editors/emacs/emacs-18.59-r5.ebuild
+++ b/app-editors/emacs/emacs-18.59-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r5.ebuild,v 1.7 2008/11/26 21:14:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r5.ebuild,v 1.8 2009/01/23 16:53:41 ulm Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -61,7 +61,7 @@ src_compile() {
replace-flags -O[3-9] -O2
strip-flags
- emake -j"1" CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" || die
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" || die
}
src_install() {
diff --git a/app-editors/emacs/emacs-18.59-r6.ebuild b/app-editors/emacs/emacs-18.59-r6.ebuild
new file mode 100644
index 000000000000..73928416971f
--- /dev/null
+++ b/app-editors/emacs/emacs-18.59-r6.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r6.ebuild,v 1.1 2009/01/23 16:53:41 ulm Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="The extensible self-documenting text editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gnu/old-gnu/emacs/${P}.tar.gz
+ ftp://ftp.splode.com/pub/users/friedman/emacs/${P}-linux22x-elf-glibc21.diff.gz
+ mirror://gentoo/${P}-patches-3.tar.bz2"
+
+LICENSE="GPL-1 GPL-2 BSD as-is"
+SLOT="18"
+KEYWORDS="~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ X? ( x11-libs/libX11[-xcb] )"
+DEPEND="${RDEPEND}"
+
+MY_BASEDIR="/usr/share/emacs/${PV}"
+MY_LOCKDIR="/var/lib/emacs/lock"
+
+src_prepare() {
+ epatch "${WORKDIR}/${P}-linux22x-elf-glibc21.diff"
+ EPATCH_SUFFIX=patch epatch
+}
+
+src_configure() {
+ # autoconf? What's autoconf? We are living in 1992. ;-)
+ local arch
+ case ${ARCH} in
+ x86) arch=intel386 ;;
+ *) die "Architecture ${ARCH} not supported" ;;
+ esac
+ local cmd="s/\"s-.*\.h\"/\"s-linux.h\"/;s/\"m-.*\.h\"/\"m-${arch}.h\"/"
+ use X && cmd="${cmd};s/.*\(#define HAVE_X_WINDOWS\).*/\1/"
+ sed -e "${cmd}" src/config.h-dist >src/config.h
+
+ cat <<-END >src/paths.h
+ #define PATH_LOADSEARCH "${MY_BASEDIR}/lisp"
+ #define PATH_EXEC "${MY_BASEDIR}/etc"
+ #define PATH_LOCK "${MY_LOCKDIR}/"
+ #define PATH_SUPERLOCK "${MY_LOCKDIR}/!!!SuperLock!!!"
+ END
+
+ # -O3 and -finline-functions cause segmentation faults at run time.
+ filter-flags -finline-functions
+ replace-flags -O[3-9] -O2
+ strip-flags
+}
+
+src_compile() {
+ # Do not use the sandbox, or the dumped Emacs will be twice as large
+ SANDBOX_ON=0
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" || die
+}
+
+src_install() {
+ local i
+
+ dodir ${MY_BASEDIR}
+ dodir /usr/share/man/man1
+ make install LIBDIR="${D}${MY_BASEDIR}" BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man/man1" || die
+ chmod -R go-w "${D}${MY_BASEDIR}"
+ rmdir "${D}${MY_BASEDIR}/lock"
+
+ dodir ${MY_LOCKDIR%/*}
+ diropts -m0777
+ keepdir ${MY_LOCKDIR}
+
+ for i in emacsclient etags ctags; do
+ mv "${D}"/usr/bin/${i}{,-emacs-${SLOT}} || die "mv ${i} failed"
+ done
+ mv "${D}"/usr/bin/emacs{,-${SLOT}} || die "mv emacs failed"
+ mv "${D}"/usr/share/man/man1/emacs{,-emacs-${SLOT}}.1 || die
+ dosym ../emacs/${PV}/info /usr/share/info/emacs-${SLOT}
+
+ dodoc README PROBLEMS
+}
+
+pkg_postinst() {
+ eselect emacs update ifunset
+}
+
+pkg_postrm() {
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
index 7ef4be9b35d0..74e0827dd067 100644
--- a/app-editors/emacs/metadata.xml
+++ b/app-editors/emacs/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>emacs</herd>
<longdescription>
- GNU Emacs is an extensible, customizable text editor—and more. At its core
+ GNU Emacs is an extensible, customizable text editor - and more. At its core
is an interpreter for Emacs Lisp, a dialect of the Lisp programming language
with extensions to support text editing. The features of GNU Emacs include:
* Content-sensitive editing modes, including syntax coloring, for a wide