summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-09 16:39:43 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-09 16:39:43 +0000
commitc773414b281279d19041492ed3d2c5a39e63b647 (patch)
treea12b60873757754bf408f0e264d8341cd78fdba6 /app-editors
parentStable for HPPA (bug #530512). (diff)
downloadgentoo-2-c773414b281279d19041492ed3d2c5a39e63b647.tar.gz
gentoo-2-c773414b281279d19041492ed3d2c5a39e63b647.tar.bz2
gentoo-2-c773414b281279d19041492ed3d2c5a39e63b647.zip
Simplify library checks, drop virtual/pkgconfig (maybe bug #536128).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hexcurse/ChangeLog8
-rw-r--r--app-editors/hexcurse/files/1.55-tinfo.patch6
-rw-r--r--app-editors/hexcurse/hexcurse-1.55.ebuild6
3 files changed, 13 insertions, 7 deletions
diff --git a/app-editors/hexcurse/ChangeLog b/app-editors/hexcurse/ChangeLog
index 1e594743ccfb..b77a58a9adfd 100644
--- a/app-editors/hexcurse/ChangeLog
+++ b/app-editors/hexcurse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/hexcurse
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/ChangeLog,v 1.12 2014/10/27 23:25:27 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/ChangeLog,v 1.13 2015/01/09 16:39:43 jer Exp $
+
+ 09 Jan 2015; Jeroen Roovers <jer@gentoo.org> hexcurse-1.55.ebuild,
+ files/1.55-tinfo.patch:
+ Simplify library checks, drop virtual/pkgconfig (maybe bug #536128).
27 Oct 2014; Jeroen Roovers <jer@gentoo.org> hexcurse-1.55.ebuild,
files/1.55-gcc.patch, +files/1.55-tinfo.patch:
diff --git a/app-editors/hexcurse/files/1.55-tinfo.patch b/app-editors/hexcurse/files/1.55-tinfo.patch
index 68d89a18e7e2..f258c06f1cf7 100644
--- a/app-editors/hexcurse/files/1.55-tinfo.patch
+++ b/app-editors/hexcurse/files/1.55-tinfo.patch
@@ -1,11 +1,13 @@
--- a/configure.in
+++ b/configure.in
-@@ -13,7 +13,7 @@
+@@ -13,7 +13,9 @@
dnl Checks for libraries.
dnl Replace `main' with a function in -lncurses:
-AC_CHECK_LIB(ncurses, initscr,,AC_CHECK_LIB(curses, initscr))
-+PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",)
++AC_CHECK_LIB(ncurses, initscr)
++AC_SEARCH_LIBS(initscr,curses)
++AC_SEARCH_LIBS(LINES,tinfo)
dnl Checks for header files.
AC_HEADER_STDC
diff --git a/app-editors/hexcurse/hexcurse-1.55.ebuild b/app-editors/hexcurse/hexcurse-1.55.ebuild
index 8da6fd2f9ba1..6fcf8009775d 100644
--- a/app-editors/hexcurse/hexcurse-1.55.ebuild
+++ b/app-editors/hexcurse/hexcurse-1.55.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.16 2014/10/27 23:25:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.17 2015/01/09 16:39:43 jer Exp $
EAPI=5
inherit autotools eutils
@@ -16,13 +16,13 @@ KEYWORDS="alpha amd64 arm hppa ppc s390 sh sparc x86 ~x86-interix ~amd64-linux ~
RDEPEND=">=sys-libs/ncurses-5.2"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
"
src_prepare() {
epatch \
"${FILESDIR}"/${PV}-gcc.patch \
"${FILESDIR}"/${PV}-tinfo.patch
+
eautoreconf
}