summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-03-20 06:32:39 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-03-20 06:32:39 +0000
commitc67caf91cd014531329972f4a01f294deccd3204 (patch)
tree65aeceadcb0b38108c7e24afaec8b231a437f908 /app-editors
parentadd a menu entry for bug #166256 (diff)
downloadgentoo-2-c67caf91cd014531329972f4a01f294deccd3204.tar.gz
gentoo-2-c67caf91cd014531329972f4a01f294deccd3204.tar.bz2
gentoo-2-c67caf91cd014531329972f4a01f294deccd3204.zip
version bump for 22.0.96 pretest
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-cvs/ChangeLog9
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.96.ebuild212
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r6.ebuild217
-rw-r--r--app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.963
-rw-r--r--app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r60
5 files changed, 440 insertions, 1 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index b0c7a739c567..dca5a67ad85b 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.94 2007/03/18 15:31:37 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.95 2007/03/20 06:32:39 opfer Exp $
+
+*emacs-cvs-22.0.9999-r6 (20 Mar 2007)
+*emacs-cvs-22.0.96 (20 Mar 2007)
+
+ 20 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
+ +emacs-cvs-22.0.96.ebuild, +emacs-cvs-22.0.9999-r6.ebuild:
+ version bump for 22.0.96 pretest
18 Mar 2007; Fabian Groffen <grobian@gentoo.org>
-files/emacs-cvs-21.3.50-nofink.diff,
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.96.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.96.ebuild
new file mode 100644
index 000000000000..8516792dc75d
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.96.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.96.ebuild,v 1.1 2007/03/20 06:32:39 opfer Exp $
+
+WANT_AUTOCONF="2.61"
+WANT_AUTOMAKE="latest"
+
+inherit alternatives autotools elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+SRC_URI="ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+IUSE="alsa aqua gif gnome gtk gzip-el jpeg lesstif motif nls png spell source tiff toolkit-scroll-bars X Xaw3d "
+
+RESTRICT="$RESTRICT nostrip"
+
+X_DEPEND="x11-libs/libXmu x11-libs/libXpm x11-libs/libXt x11-misc/xbitmaps || ( media-fonts/font-adobe-100dpi media-fonts/font-adobe-75dpi )"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ X? ( $X_DEPEND )
+ X? ( gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ gnome? ( gnome-base/gnome-desktop ) )
+ alsa? ( media-sound/alsa-headers )
+ gzip-el? ( app-arch/gzip )
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/emacs virtual/editor"
+
+SLOT="22.0.96"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+S="${WORKDIR}/emacs-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and compresses
+ # el files. We don't want that so confuse it with a wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in || die "unable to sed configure.in"
+ fi
+
+ epatch "${FILESDIR}/${PN}-freebsd-sparc.patch"
+ use ppc-macos && epatch "${FILESDIR}/emacs-cvs-21.3.50-nofink.diff"
+
+ eautoreconf
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=""
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d(athena) support"
+ myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=lucid"
+ elif use motif; then
+ einfo "Configuring to build with motif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ elif use lesstif; then
+ einfo "Configuring to build with lesstif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if use aqua; then
+ einfo "Configuring to build with Carbon Emacs"
+ econf \
+ --enable-carbon-app=/Applications/Gentoo \
+ --without-x \
+ $(use_with jpeg) $(use_with tiff) \
+ $(use_with gif) $(use_with png) \
+ || die "econf carbon emacs failed"
+ else
+ econf \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ fi
+
+ emake CC="$(tc-getCC) " bootstrap \
+ || die "make bootstrap failed."
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${SLOT}.emacs-${SLOT} || die "removing duplicate emacs executable failed"
+ dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT} || die
+
+ if use aqua ; then
+ einfo "Installing Carbon Emacs..."
+ dodir /Applications/Gentoo/Emacs.app
+ pushd mac/Emacs.app
+ tar -chf - . | ( cd "${D}/Applications/Gentoo/Emacs.app"; tar -xf -)
+ popd
+ fi
+
+ # fix info documentation
+ einfo "Fixing info documentation..."
+ dodir /usr/share/info/emacs-${SLOT}
+ mv "${D}"/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
+ for i in "${D}"/usr/share/info/*
+ do
+ if [ "${i##*/}" != emacs-${SLOT} ] ; then
+ mv ${i} ${i/info/info/emacs-${SLOT}}.info
+ fi
+ done
+
+ insinto /etc/env.d
+ cat >"${D}"/etc/env.d/50emacs-cvs-${SLOT} <<EOF
+INFOPATH=/usr/share/info/emacs-${SLOT}
+EOF
+ einfo "Fixing manpages..."
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv man failed"
+ done
+
+ # avoid collision between slots
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+
+ if use source; then
+ insinto /usr/share/emacs/${SLOT}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ cat >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+(when (substring emacs-version 0 (length "${SLOT}"))
+ (setq find-function-C-source-directory "/usr/share/emacs/${SLOT}/src"))
+EOF
+ elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ fi
+
+ dodoc BUGS ChangeLog README
+}
+
+update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=$(echo /usr/share/man/man1/emacs.emacs-*.1*|sed 's/.*\.1//')
+
+ # this creates symlinks for binaries and man pages, so the correct ones in a slotted
+ # environment can be accessed
+ for i in emacs emacsclient etags ctags b2m ebrowse \
+ rcs-checkin grep-changelog ;
+ do
+ alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/$i.emacs-*"
+ done
+
+ for j in emacs emacsclient etags ctags
+ do
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1${suffix}" "/usr/share/man/man1/$j.emacs-*"
+ done
+}
+
+pkg_postinst() {
+ test -f ${ROOT}/usr/share/emacs/site-lisp/subdirs.el ||
+ cp ${ROOT}/usr/share/emacs{/${SLOT},}/site-lisp/subdirs.el
+
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+
+ # ecompress from Portage 2.2.* does auto-compression
+ # which is not desired for the dir file, so remove it to
+ # let it be recreated
+ rm "${ROOT}/usr/share/info/emacs-${SLOT}/dir.*" 2> /dev/null
+
+ if use X; then
+ elog "You need to install some fonts for Emacs. Under monolithic"
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic"
+ elog "Emacs requirements under X11."
+ fi
+}
+
+pkg_postrm() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+}
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r6.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r6.ebuild
new file mode 100644
index 000000000000..714ed414030e
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r6.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r6.ebuild,v 1.1 2007/03/20 06:32:39 opfer Exp $
+
+ECVS_AUTH="pserver"
+ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
+ECVS_MODULE="emacs"
+ECVS_BRANCH="HEAD"
+
+WANT_AUTOCONF="2.61"
+WANT_AUTOMAKE="latest"
+
+inherit alternatives autotools cvs elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+SRC_URI=""
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+IUSE="alsa aqua gif gnome gtk gzip-el jpeg lesstif motif nls png spell source tiff toolkit-scroll-bars X Xaw3d "
+
+RESTRICT="$RESTRICT nostrip"
+
+X_DEPEND="x11-libs/libXmu x11-libs/libXpm x11-libs/libXt x11-misc/xbitmaps || ( media-fonts/font-adobe-100dpi media-fonts/font-adobe-75dpi )"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ X? ( $X_DEPEND )
+ X? ( gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ gnome? ( gnome-base/gnome-desktop ) )
+ alsa? ( media-sound/alsa-headers )
+ gzip-el? ( app-arch/gzip )
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/emacs virtual/editor"
+
+SLOT="22.0.96"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+S="${WORKDIR}/emacs"
+
+src_unpack() {
+ cvs_src_unpack
+
+ cd "${S}"
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and compresses
+ # el files. We don't want that so confuse it with a wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in || die "unable to sed configure.in"
+ fi
+
+ epatch "${FILESDIR}/${PN}-freebsd-sparc.patch"
+ use ppc-macos && epatch "${FILESDIR}/emacs-cvs-21.3.50-nofink.diff"
+
+ eautoreconf
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=""
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d(athena) support"
+ myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=lucid"
+ elif use motif; then
+ einfo "Configuring to build with motif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ elif use lesstif; then
+ einfo "Configuring to build with lesstif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if use aqua; then
+ einfo "Configuring to build with Carbon Emacs"
+ econf \
+ --enable-carbon-app=/Applications/Gentoo \
+ --without-x \
+ $(use_with jpeg) $(use_with tiff) \
+ $(use_with gif) $(use_with png) \
+ || die "econf carbon emacs failed"
+ else
+ econf \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ fi
+
+ emake CC="$(tc-getCC) " bootstrap \
+ || die "make bootstrap failed."
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${SLOT}.emacs-${SLOT} || die "removing duplicate emacs executable failed"
+ dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT} || die
+
+ if use aqua ; then
+ einfo "Installing Carbon Emacs..."
+ dodir /Applications/Gentoo/Emacs.app
+ pushd mac/Emacs.app
+ tar -chf - . | ( cd "${D}/Applications/Gentoo/Emacs.app"; tar -xf -)
+ popd
+ fi
+
+ # fix info documentation
+ einfo "Fixing info documentation..."
+ dodir /usr/share/info/emacs-${SLOT}
+ mv "${D}"/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
+ for i in "${D}"/usr/share/info/*
+ do
+ if [ "${i##*/}" != emacs-${SLOT} ] ; then
+ mv ${i} ${i/info/info/emacs-${SLOT}}.info
+ fi
+ done
+
+ insinto /etc/env.d
+ cat >"${D}"/etc/env.d/50emacs-cvs-${SLOT} <<EOF
+INFOPATH=/usr/share/info/emacs-${SLOT}
+EOF
+ einfo "Fixing manpages..."
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv man failed"
+ done
+
+ # avoid collision between slots
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+
+ if use source; then
+ insinto /usr/share/emacs/${SLOT}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ cat >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+(when (substring emacs-version 0 (length "${SLOT}"))
+ (setq find-function-C-source-directory "/usr/share/emacs/${SLOT}/src"))
+EOF
+ elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ fi
+
+ dodoc BUGS ChangeLog README
+}
+
+update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=$(echo /usr/share/man/man1/emacs.emacs-*.1*|sed 's/.*\.1//')
+
+ # this creates symlinks for binaries and man pages, so the correct ones in a slotted
+ # environment can be accessed
+ for i in emacs emacsclient etags ctags b2m ebrowse \
+ rcs-checkin grep-changelog ;
+ do
+ alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/$i.emacs-*"
+ done
+
+ for j in emacs emacsclient etags ctags
+ do
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1${suffix}" "/usr/share/man/man1/$j.emacs-*"
+ done
+}
+
+pkg_postinst() {
+ test -f ${ROOT}/usr/share/emacs/site-lisp/subdirs.el ||
+ cp ${ROOT}/usr/share/emacs{/${SLOT},}/site-lisp/subdirs.el
+
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+
+ # ecompress from Portage 2.2.* does auto-compression
+ # which is not desired for the dir file, so remove it to
+ # let it be recreated
+ rm "${ROOT}/usr/share/info/emacs-${SLOT}/dir.*" 2> /dev/null
+
+ if use X; then
+ elog "You need to install some fonts for Emacs. Under monolithic"
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic"
+ elog "Emacs requirements under X11."
+ fi
+}
+
+pkg_postrm() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+}
diff --git a/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.96 b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.96
new file mode 100644
index 000000000000..4797c8cee129
--- /dev/null
+++ b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.96
@@ -0,0 +1,3 @@
+MD5 09fabcb5becb050acf1c88639330dac6 emacs-22.0.96.tar.gz 37846686
+RMD160 d980f7f8ec6c646a9b741718284b081987f9d73c emacs-22.0.96.tar.gz 37846686
+SHA256 a9fa904e00e09d8b68e701edda208bd274053d26d0b50d97d6c977084e5c307d emacs-22.0.96.tar.gz 37846686
diff --git a/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r6 b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r6
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r6