summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-05-09 15:02:08 +0000
committerUlrich Müller <ulm@gentoo.org>2009-05-09 15:02:08 +0000
commitbe50369d3a1ee81304885e1e8375d5e410d4f8df (patch)
tree1ad09a07733fdc2e10d297ac94f01cecb491c873 /app-editors
parentStable on alpha, bug #268671 (diff)
downloadgentoo-2-be50369d3a1ee81304885e1e8375d5e410d4f8df.tar.gz
gentoo-2-be50369d3a1ee81304885e1e8375d5e410d4f8df.tar.bz2
gentoo-2-be50369d3a1ee81304885e1e8375d5e410d4f8df.zip
Version bump. Add BSD to LICENSE.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emact/ChangeLog10
-rw-r--r--app-editors/emact/emact-2.53.0.ebuild6
-rw-r--r--app-editors/emact/emact-2.54.0.ebuild34
3 files changed, 45 insertions, 5 deletions
diff --git a/app-editors/emact/ChangeLog b/app-editors/emact/ChangeLog
index 4b35a7af8523..72bf178e873f 100644
--- a/app-editors/emact/ChangeLog
+++ b/app-editors/emact/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/emact
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emact/ChangeLog,v 1.14 2008/10/24 17:24:16 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emact/ChangeLog,v 1.15 2009/05/09 15:02:08 ulm Exp $
+
+*emact-2.54.0 (09 May 2009)
+
+ 09 May 2009; Ulrich Mueller <ulm@gentoo.org> emact-2.53.0.ebuild,
+ +emact-2.54.0.ebuild:
+ Version bump. Add BSD to LICENSE.
24 Oct 2008; Ulrich Mueller <ulm@gentoo.org> emact-2.53.0.ebuild:
Inherit toolchain-funcs and export CC variable, bug 243560.
diff --git a/app-editors/emact/emact-2.53.0.ebuild b/app-editors/emact/emact-2.53.0.ebuild
index 4227de802245..b6e8e2551508 100644
--- a/app-editors/emact/emact-2.53.0.ebuild
+++ b/app-editors/emact/emact-2.53.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emact/emact-2.53.0.ebuild,v 1.3 2008/10/24 17:24:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emact/emact-2.53.0.ebuild,v 1.4 2009/05/09 15:02:08 ulm Exp $
inherit toolchain-funcs
@@ -8,7 +8,7 @@ DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
HOMEPAGE="http://www.eligis.com/emacs/"
SRC_URI="http://www.eligis.com/emacs/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="X"
diff --git a/app-editors/emact/emact-2.54.0.ebuild b/app-editors/emact/emact-2.54.0.ebuild
new file mode 100644
index 000000000000..557edf410909
--- /dev/null
+++ b/app-editors/emact/emact-2.54.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emact/emact-2.54.0.ebuild,v 1.1 2009/05/09 15:02:08 ulm Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="http://www.eligis.com/emacs/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ X? (
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CC
+ econf $(use_with X x) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install || die "emake install failed"
+ dodoc README || die "dodoc failed"
+}