summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-11-17 18:49:57 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-11-17 18:49:57 +0000
commitba121462560c90672d54804e08261a5c8b652448 (patch)
treed3f8b596e838127420b65adbb8449c622a7d9ca7 /app-editors
parentInitial import, thanks to Didier Barvaux (bug #293288) (diff)
downloadgentoo-2-ba121462560c90672d54804e08261a5c8b652448.tar.gz
gentoo-2-ba121462560c90672d54804e08261a5c8b652448.tar.bz2
gentoo-2-ba121462560c90672d54804e08261a5c8b652448.zip
Version bump. Added a dirty patch which fixes automagic installation of the charmap plugin.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog9
-rw-r--r--app-editors/bluefish/bluefish-1.3.8.ebuild80
-rw-r--r--app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch60
3 files changed, 148 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 7d88810d7818..d8dfc6fbe812 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/bluefish
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.65 2009/09/23 12:31:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.66 2009/11/17 18:49:57 billie Exp $
+
+*bluefish-1.3.8 (17 Nov 2009)
+
+ 17 Nov 2009; Daniel Pielmeier <billie@gentoo.org> +bluefish-1.3.8.ebuild,
+ +files/bluefish-1.3.8-gucharmap-automagic.patch:
+ Version bump. Added a dirty patch which fixes automagic installation of
+ the charmap plugin.
*bluefish-1.3.7 (23 Sep 2009)
diff --git a/app-editors/bluefish/bluefish-1.3.8.ebuild b/app-editors/bluefish/bluefish-1.3.8.ebuild
new file mode 100644
index 000000000000..855fa3d2cb52
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.3.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.3.8.ebuild,v 1.1 2009/11/17 18:49:57 billie Exp $
+
+EAPI="2"
+
+inherit autotools eutils fdo-mime
+
+IUSE="nls spell gnome python"
+
+MY_P="${PN}-unstable-${PV}"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://www.bennewitz.com/bluefish/devel/source/${MY_P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/libpcre
+ x11-libs/gtk+:2
+ spell? ( app-text/enchant[aspell] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-util/pkgconfig
+ x11-libs/pango
+ gnome? ( gnome-extra/gucharmap )
+ nls? ( sys-devel/gettext dev-util/intltool )
+ python? ( dev-lang/python )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare () {
+ # Fixes automagic installation of charmap plugin
+ # Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=570990
+ epatch "${FILESDIR}"/${P}-gucharmap-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-update-databases \
+ --disable-xml-catalog-update \
+ $(use_enable nls) \
+ $(use_enable spell spell-check) \
+ $(use_enable gnome charmap) \
+ $(use_enable python)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo "Adding XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ /etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ einfo "Removing XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ /etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}
diff --git a/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch b/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch
new file mode 100644
index 000000000000..2d286ad30a68
--- /dev/null
+++ b/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch
@@ -0,0 +1,60 @@
+--- configure.ac.old 2009-11-16 22:05:28.000000000 +0100
++++ configure.ac 2009-11-16 23:46:49.000000000 +0100
+@@ -415,29 +415,38 @@
+
+ PKG_CHECK_MODULES([BLUEFISH_REQUIRED], [$BF_dependencies])
+
+-# optionally build the charmap plugin if gucharmap is available
+-PKG_CHECK_MODULES(
+- [CHARMAP_PLUGIN],
+- [gucharmap-2],
+- [
+- build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+- ],
+- [PKG_CHECK_MODULES(
++# build the charmap plugin
++
++AC_ARG_ENABLE(
++ [charmap],
++ AC_HELP_STRING(
++ [--enable-charmap],
++ [enable (or disable) the charmap plugin needs gucharmap @<:@default=no@:>@]
++ )
++)
++
++if test "x$enable_charmap" != "xno"; then
++ PKG_CHECK_MODULES(
+ [CHARMAP_PLUGIN],
+- [gucharmap >= 2.20],
++ [gucharmap-2],
+ [
+ build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+ ],
+- [
+- build_charmap_plugin=no
+- AC_MSG_WARN([Disabling the building of the charmap plugin.])
+- AC_MSG_WARN([Install gucharmap/gucharmap2 (>= 2.20) library/headers to build the plugin.])
+- ]
+- )]
+-)
+-AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++ [PKG_CHECK_MODULES(
++ [CHARMAP_PLUGIN],
++ [gucharmap >= 2.20],
++ [
++ build_charmap_plugin=yes
++ AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ ],
++ )]
++ )
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++else
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xno"])
++ AC_MSG_NOTICE([Disable building charmap plugin.])
++fi
+
+ AC_SEARCH_LIBS([nanosleep], [posix4 rt])
+