summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-08-19 04:44:27 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-08-19 04:44:27 +0000
commitb359a6b1c16f79faae16f3a4b48a7fd4072a9050 (patch)
tree2764750bfcc613a4ac503e2c5ca0ad009d6ea2e9 /app-editors
parentx86 stable wrt security bug #375167 (diff)
downloadgentoo-2-b359a6b1c16f79faae16f3a4b48a7fd4072a9050.tar.gz
gentoo-2-b359a6b1c16f79faae16f3a4b48a7fd4072a9050.tar.bz2
gentoo-2-b359a6b1c16f79faae16f3a4b48a7fd4072a9050.zip
Version bump (bug #373665 by Gary Hunt). Also respect compiler flags, fix
parallel build, and use system version of udis86. (Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/ChangeLog11
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch96
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.11.ebuild30
3 files changed, 135 insertions, 2 deletions
diff --git a/app-editors/wxhexeditor/ChangeLog b/app-editors/wxhexeditor/ChangeLog
index 9010cb22ccdb..008d49481364 100644
--- a/app-editors/wxhexeditor/ChangeLog
+++ b/app-editors/wxhexeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/wxhexeditor
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.2 2011/08/19 04:44:27 dirtyepic Exp $
+
+*wxhexeditor-0.11 (19 Aug 2011)
+
+ 19 Aug 2011; Ryan Hill <dirtyepic@gentoo.org> +wxhexeditor-0.11.ebuild,
+ +files/wxhexeditor-0.11-makefile.patch:
+ Version bump (bug #373665 by Gary Hunt). Also respect compiler flags, fix
+ parallel build, and use system version of udis86.
*wxhexeditor-0.09 (31 Aug 2010)
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch
new file mode 100644
index 000000000000..10180c9b2877
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch
@@ -0,0 +1,96 @@
+https://bugs.gentoo.org/373665
+
+ use system udis86
+ respect flags
+ fix parallel build
+
+--- a/hashlibpp/src/Makefile
++++ b/hashlibpp/src/Makefile
+@@ -50,7 +50,7 @@ INCLUDE_PATH = /usr/include/hashlib++
+ LIB_PATH = /usr/local/lib/
+
+ # Compiler to use
+-COMPILER = g++
++COMPILER = ${CXX}
+
+ # Global options for the compiler
+ COPTIONS = -ansi -Wall -Wextra
+@@ -62,7 +62,7 @@ COPTIONS = -ansi -Wall -Wextra
+ ifdef DEBUG
+ COPTIONS += -g
+ else
+- COPTIONS += -O3 -fomit-frame-pointer
++ COPTIONS += ${CXXFLAGS}
+ endif
+
+ GCC = $(COMPILER) $(COPTIONS)
+@@ -149,7 +149,7 @@ hl_sha512wrapper.o: hl_sha512wrapper.cpp hl_sha512wrapper.h
+ #-----------------------------------------------------------------------
+ # Creating a static lib using ar
+
+-LIB: MD5 SHA1 SHA256
++LIB: MD5 SHA1 SHA256 SHA2EXT
+ ar rs libhl++.a $(MD5) $(SHA1) $(SHA256) $(SHA2EXT)
+
+ #-----------------------------------------------------------------------
+--- a/makefile
++++ b/makefile
+@@ -1,7 +1,7 @@
+ WXCONFIG = wx-config
+ CPP = `$(WXCONFIG) --cxx`
+-CXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -MMD -c ${OPTFLAGS}
+-LDFLAGS = `$(WXCONFIG) --libs`
++WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -c ${OPTFLAGS}
++WXLDFLAGS = `$(WXCONFIG) --libs` ${LDFLAGS}
+ RC = `$(WXCONFIG) --rescomp`
+ #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
+ RCFLAGS = `$(WXCONFIG) --cxxflags | sed s/' '-m.*//g;`
+@@ -17,7 +17,7 @@ SOURCES= src/HexEditorGui.cpp \
+ src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
+ src/HexEditorCtrl/HexEditorCtrlGui.cpp\
+ src/HexEditorFrame.cpp
+-LIBS = udis86/libudis86/.libs/libudis86.a hashlibpp/src/libhl++.a
++LIBS = hashlibpp/src/libhl++.a
+ OBJECTS=$(SOURCES:.cpp=.o)
+ DEPENDS=$(OBJECTS:.o=.d)
+ RESOURCES= resources/resource.rc
+@@ -39,19 +39,19 @@ all: prepare $(EXECUTABLE)
+ prepare: $(LIBS) $(SOURCES)
+
+ $(EXECUTABLE): $(OBJECTS) $(LIBS)
+- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -o $@
++ $(CPP) $(OBJECTS) $(LIBS) -ludis86 $(WXLDFLAGS) ${LDFLAGS} -o $@
+
+ .cpp.o:
+- $(CPP) $(CXXFLAGS) $< -o $@
++ $(CPP) $(WXCXXFLAGS) ${CXXFLAGS} $< -o $@
+
+ %.o : %.rc
+ $(RC) $(RCFLAGS) $< -o $@
+
+-udis86/libudis86/.libs/libudis86.a:
+- echo Please make sure if libudis86 build for your host to avoid link time errors!
+- cd udis86;./autogen.sh
+- cd udis86;./configure
+- cd udis86/libudis86; $(MAKE) $(MFLAGS)
++#udis86/libudis86/.libs/libudis86.a:
++# echo Please make sure if libudis86 build for your host to avoid link time errors!
++# cd udis86;./autogen.sh
++# cd udis86;./configure
++# cd udis86/libudis86; $(MAKE) $(MFLAGS)
+
+ hashlibpp/src/libhl++.a:
+ echo "Please make sure if libudis86 build for your host to avoid link time errors!"
+@@ -61,10 +61,10 @@ win: prepare $(RESOURCES) $(EXECUTABLE_WIN)
+
+ #Stack override required for file comparison function...
+ $(EXECUTABLE_WIN): $(OBJECTS) $(RESOURCE_OBJ)
+- $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(LDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,5242880 -o $@
++ $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(WXLDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,5242880 ${LDFLAGS} -o $@
+
+ maclink: $(OBJECTS)
+- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -lexpat -o $(EXECUTABLE)
++ $(CPP) $(OBJECTS) $(LIBS) $(WXLDFLAGS) -lexpat ${LDFLAGS} -o $(EXECUTABLE)
+
+ mac: prepare maclink
+ mkdir -p $(EXECUTABLE_DIR_MAC)/Contents
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild
new file mode 100644
index 000000000000..4a966d4aef3d
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild,v 1.1 2011/08/19 04:44:27 dirtyepic Exp $
+
+EAPI="4"
+WX_GTK_VER="2.8"
+
+inherit eutils toolchain-funcs wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files."
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/udis86
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CXX
+}