summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-07-09 17:56:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-07-09 17:56:05 +0000
commitb24a4df3f4f61c138ca2392603ed0ae6caa3e74f (patch)
tree98d248f2ed29a3924edb0b0ae49e42e8d8b93761 /app-editors
parentsci-biology/allpathslg: Version bump, fix compilation errors with gcc-4.7, #4... (diff)
downloadgentoo-2-b24a4df3f4f61c138ca2392603ed0ae6caa3e74f.tar.gz
gentoo-2-b24a4df3f4f61c138ca2392603ed0ae6caa3e74f.tar.bz2
gentoo-2-b24a4df3f4f61c138ca2392603ed0ae6caa3e74f.zip
Fix compilation with gcc-4.7. Bug #425252
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qwriter/ChangeLog7
-rw-r--r--app-editors/qwriter/files/qwriter-0.1.9-gcc47.patch13
-rw-r--r--app-editors/qwriter/qwriter-0.1.9.ebuild4
3 files changed, 21 insertions, 3 deletions
diff --git a/app-editors/qwriter/ChangeLog b/app-editors/qwriter/ChangeLog
index b4bc02736f38..293c8700b352 100644
--- a/app-editors/qwriter/ChangeLog
+++ b/app-editors/qwriter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/qwriter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qwriter/ChangeLog,v 1.4 2012/05/21 19:57:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qwriter/ChangeLog,v 1.5 2012/07/09 17:56:05 hwoarang Exp $
+
+ 09 Jul 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/qwriter-0.1.9-gcc47.patch, qwriter-0.1.9.ebuild:
+ Fix compilation with gcc-4.7. Bug #425252
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> qwriter-0.1.9.ebuild:
inherit eutils for make_desktop_entry
@@ -16,4 +20,3 @@
21 May 2010; Markos Chandras <hwoarang@gentoo.org> +qwriter-0.1.9.ebuild,
+metadata.xml:
Initial commit of qwriter application. Moved from qting-edge overlay
-
diff --git a/app-editors/qwriter/files/qwriter-0.1.9-gcc47.patch b/app-editors/qwriter/files/qwriter-0.1.9-gcc47.patch
new file mode 100644
index 000000000000..d13c6625a743
--- /dev/null
+++ b/app-editors/qwriter/files/qwriter-0.1.9-gcc47.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=425252
+Index: qwriter-0.1.9-src/qtsingleapplication-2.6-opensource/linux/src/qtlocalpeer.cpp
+===================================================================
+--- qwriter-0.1.9-src.orig/qtsingleapplication-2.6-opensource/linux/src/qtlocalpeer.cpp
++++ qwriter-0.1.9-src/qtsingleapplication-2.6-opensource/linux/src/qtlocalpeer.cpp
+@@ -56,6 +56,7 @@ typedef BOOL(WINAPI*PProcessIdToSessionI
+ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
++#include <unistd.h>
+ #include <time.h>
+ #endif
+
diff --git a/app-editors/qwriter/qwriter-0.1.9.ebuild b/app-editors/qwriter/qwriter-0.1.9.ebuild
index c635c7dc91e4..31b6606a86af 100644
--- a/app-editors/qwriter/qwriter-0.1.9.ebuild
+++ b/app-editors/qwriter/qwriter-0.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qwriter/qwriter-0.1.9.ebuild,v 1.4 2012/05/21 19:57:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qwriter/qwriter-0.1.9.ebuild,v 1.5 2012/07/09 17:56:05 hwoarang Exp $
EAPI="2"
LANGS="ru"
@@ -28,6 +28,8 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
sed -i "s:languages:/usr/share/${PN}/languages:" src/MainWindow.cpp \
|| die "failed to fix translation path"
+ # gcc-4.7. Bug #425252
+ epatch "${FILESDIR}"/${P}-gcc47.patch
qt4-r2_src_prepare
}