summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 17:17:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 17:17:39 +0000
commita697673924fb876b4b9e7b4a27512bc36454fdbc (patch)
tree8ace63781a8717adc1437814aa6db7f17726b1ef /app-editors
parentMask dev-perl/XML-LibXML-Common and dev-perl/Email-Simple-Creator (diff)
downloadgentoo-2-a697673924fb876b4b9e7b4a27512bc36454fdbc.tar.gz
gentoo-2-a697673924fb876b4b9e7b4a27512bc36454fdbc.tar.bz2
gentoo-2-a697673924fb876b4b9e7b4a27512bc36454fdbc.zip
Delete older ebuilds.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/leo/files/leoConfig.py.patch27
-rw-r--r--app-editors/leo/leo-4.2.ebuild45
-rw-r--r--app-editors/leo/leo-4.4.7-r1.ebuild59
3 files changed, 0 insertions, 131 deletions
diff --git a/app-editors/leo/files/leoConfig.py.patch b/app-editors/leo/files/leoConfig.py.patch
deleted file mode 100644
index 8d16872a9071..000000000000
--- a/app-editors/leo/files/leoConfig.py.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/leoConfig.py 2004-07-20 08:11:58.000000000 -0700
-+++ leoConfig.py 2004-11-08 22:49:31.055019376 -0800
-@@ -9,6 +9,7 @@
- import os
- import string
- import sys
-+import shutil
-
- class baseConfig:
- """The base class for Leo's configuration handler."""
-@@ -84,10 +85,12 @@
-
- def init (self):
-
-- try:
-- self.configDir = sys.leo_config_directory
-- except:
-- self.configDir = g.os_path_join(g.app.loadDir,"..","config")
-+ self.configDir = os.path.expanduser("~/.leo")
-+ if not os.path.exists(self.configDir):
-+ os.mkdir(self.configDir)
-+ config_file = "%s/leoConfig.txt" % \
-+ g.os_path_join(g.app.loadDir,"..","config")
-+ shutil.copy(config_file, self.configDir)
-
- self.configFileName = g.os_path_join(self.configDir,"leoConfig.txt")
-
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
deleted file mode 100644
index 129a3f7f453f..000000000000
--- a/app-editors/leo/leo-4.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.7 2007/06/23 09:56:19 hawking Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils python
-
-MY_P=${P}-final
-DESCRIPTION="Leo is an outlining editor and literate programming tool."
-HOMEPAGE="http://leo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="PYTHON"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- python_tkinter_exists
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die "Failed to cd ${S}"
- epatch "${FILESDIR}"/leoConfig.py.patch
-}
-
-src_install() {
- python_version
- INST_DIR=/usr/lib/python${PYVER}/site-packages/leo
- dodoc ${S}/PKG-INFO MANIFEST doc/*
- rm -rf PKG-INFO MANIFEST doc/*
- dodir ${INST_DIR}
- cp -r * "${D}"/${INST_DIR}/ || die "cp failed"
- echo "#!/bin/bash" > leo
- echo "exec /usr/bin/python ${INST_DIR}/src/leo.py \"\$1\"" >> leo
- exeinto /usr/bin
- doexe leo || die "doexe failed"
-}
diff --git a/app-editors/leo/leo-4.4.7-r1.ebuild b/app-editors/leo/leo-4.4.7-r1.ebuild
deleted file mode 100644
index 5acb7c605e65..000000000000
--- a/app-editors/leo/leo-4.4.7-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.4.7-r1.ebuild,v 1.1 2008/10/26 23:12:29 hawking Exp $
-
-EAPI=2
-inherit python multilib
-
-MY_P="${P}-final"
-
-DESCRIPTION="An outlining editor and literate programming tool."
-HOMEPAGE="http://leo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-LICENSE="PYTHON"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-COMMON_DEPEND=">=dev-lang/python-2.3[tk]"
-DEPEND="app-arch/unzip
- ${COMMON_DEPEND}"
-RDEPEND="app-text/silvercity
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- # Remove all CVS directories
- find . -iname "CVS" -exec rm -rf {} \; 2>/dev/null
-}
-
-src_install() {
- dohtml -r doc/html/* || die "dohtml failed"
- dodoc doc/README.TXT || die "dodoc failed"
-
- python_version
-
- insinto "/usr/$(get_libdir)/python${PYVER}/site-packages/leo"
- doins -r config extensions Icons __init__.py modes plugins scripts src ||\
- die "doins failed"
-
- cat > leo <<- _EOF_
-#!/bin/sh
-${python} /usr/$(get_libdir)/python${PYVER}/site-packages/leo/src/leo.py \$@
- _EOF_
-
- dobin leo || die "dobin failed"
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
-}