summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-09-25 03:34:53 +0000
committerJon Nelson <jnelson@gentoo.org>2002-09-25 03:34:53 +0000
commita269023bc2b0b134f4bce1f9239f14aee03c0b1e (patch)
tree86317ce39ed75dd82510cad83172cc8c0bac526b /app-editors
parenttrying mandrake patch (diff)
downloadgentoo-2-a269023bc2b0b134f4bce1f9239f14aee03c0b1e.tar.gz
gentoo-2-a269023bc2b0b134f4bce1f9239f14aee03c0b1e.tar.bz2
gentoo-2-a269023bc2b0b134f4bce1f9239f14aee03c0b1e.zip
commit fix for 8327
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog10
-rw-r--r--app-editors/vim/files/6.1_patches.80.84.diff27
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r132
-rw-r--r--app-editors/vim/vim-6.1-r13.ebuild171
4 files changed, 209 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index a7b8e1ded4ec..7446db0afab3 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.20 2002/09/21 23:55:25 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.21 2002/09/25 03:34:53 jnelson Exp $
+
+*vim-6.1-r13.ebuild (24 Sep 2002)
+ 24 Sep 2002; Jon Nelson <jnelson@gentoo.org> vim-6.1-r13.ebuild:
+ More careful application of patches
+ Patch 80 and 84 partially apply, manually fix and repair at
+ end of patch cycle.
+ Always use --without-x (that's what gvim is for)
+ This is a fix for bug 8327
*vim-6.1-r12.ebuild (21 Sep 2002)
diff --git a/app-editors/vim/files/6.1_patches.80.84.diff b/app-editors/vim/files/6.1_patches.80.84.diff
new file mode 100644
index 000000000000..584d1e0064b1
--- /dev/null
+++ b/app-editors/vim/files/6.1_patches.80.84.diff
@@ -0,0 +1,27 @@
+diff -urN /tmp/src/auto/configure src/auto/configure
+--- /tmp/src/auto/configure Tue Sep 24 20:39:56 2002
++++ src/auto/configure Tue Sep 24 20:40:22 2002
+@@ -1160,13 +1160,21 @@
+
+
+
+-if test -d /usr/local/lib; then
++have_local_include=''
++have_local_lib=''
++if test "$GCC" = yes; then
++ echo 'void f(){}' > conftest.c
++ have_local_include=`${CC-cc} -c -v conftest.c 2>&1 | grep '/usr/local/include'`
++ have_local_lib=`${CC-cc} -c -v conftest.c 2>&1 | grep '/usr/local/lib'`
++ rm -f conftest.c conftest.o
++fi
++if test -z "$have_local_lib" -a -d /usr/local/lib; then
+ tt=`echo "$LDFLAGS" | sed -e 's+-L/usr/local/lib ++g' -e 's+-L/usr/local/lib$++g'`
+ if test "$tt" = "$LDFLAGS"; then
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
+ fi
+ fi
+-if test -d /usr/local/include; then
++if test -z "$have_local_include" -a -d /usr/local/include; then
+ tt=`echo "$CPPFLAGS" | sed -e 's+-I/usr/local/include ++g' -e 's+-I/usr/local/include$++g'`
+ if test "$tt" = "$CPPFLAGS"; then
+ # Don't do this if gcc looks in /usr/local/include by default! gcc 3.1+ is rather
diff --git a/app-editors/vim/files/digest-vim-6.1-r13 b/app-editors/vim/files/digest-vim-6.1-r13
new file mode 100644
index 000000000000..db4e9cbae0be
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r13
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 47bca33d09261779066fe4dac36a1896 vimpatch-1-146.tar.bz2 107280
diff --git a/app-editors/vim/vim-6.1-r13.ebuild b/app-editors/vim/vim-6.1-r13.ebuild
new file mode 100644
index 000000000000..5a464422d467
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r13.ebuild
@@ -0,0 +1,171 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r13.ebuild,v 1.1 2002/09/25 03:34:53 jnelson Exp $
+
+# Please name the ebuild as follows. If this is followed, there
+# should be no need to modify this ebuild when the Vim version is
+# updated. (Yes it's overkill, but it was fun!)
+#
+# vim-6.0, when 6.0 is finally released
+# vim-6.0_pre9, where 9 = (i), for vim-6.0i
+# vim-6.0_pre47, where 47 = 26(a) + 21(u), for vim-6.0au
+# vim-6.0_pre72, where 72 = 52(b) + 20(t), for vim-6.0bt
+#
+# Quick reference:
+# a=1 e=5 i=9 m=13 q=17 u=21 y=25
+# b=2 f=6 j=10 n=14 r=18 v=22 z=26
+# c=3 g=7 k=11 o=15 s=19 w=23 aa=27
+# d=4 h=8 l=12 p=16 t=20 x=24 ab=28 (etc.)
+#
+# (08 Sep 2001 agriffis)
+
+set -e
+
+# Calculate the version based on the name of the ebuild
+vim_version="${PV%_pre*}"
+vim_pre="${PV##*_pre}"
+VIMPATCH="vimpatch-1-146.tar.bz2"
+
+if [ "$vim_version" = "$vim_pre" ]; then
+ # Final releases prior to 6.0 include a dash and decimal point in
+ # the directory name
+ if [ "${vim_version%%.*}" -lt 6 ]; then
+ S="$WORKDIR/vim-$vim_version"
+ else
+ S="$WORKDIR/vim${vim_version//.}"
+ fi
+ vim_letters=
+ A="vim-$vim_version.tar.bz2"
+ SRC_URI="ftp://ftp.vim.org/pub/vim/unix/$A
+ ftp://ftp.us.vim.org/pub/vim/unix/$A
+ http://www.ibiblio.org/gentoo/distfiles/${VIMPATCH}"
+elif [ "$vim_pre" -lt 27 ]; then
+ # Handle (prerelease) versions with one trailing letter
+ vim_letters=`echo $vim_pre | awk '{printf "%c", $0+96}'`
+ S="$WORKDIR/vim${vim_version//.}$vim_letters"
+ A="vim-$vim_version$vim_letters.tar.bz2"
+ SRC_URI="ftp://ftp.vim.org/pub/vim/unreleased/unix/$A
+ ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
+ http://www.ibiblio.org/gentoo/distfiles/${VIMPATCH}"
+
+elif [ "$vim_pre" -lt 703 ]; then
+ # Handle (prerelease) versions with two trailing letters
+ vim_letters=`echo $vim_pre | awk '{printf "%c%c", $0/26+96, $0%26+96}'`
+ S="$WORKDIR/vim${vim_version//.}$vim_letters"
+ A="vim-$vim_version$vim_letters.tar.bz2"
+ SRC_URI="ftp://ftp.vim.org/pub/vim/unreleased/unix/$A
+ ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
+ http://www.ibiblio.org/gentoo/distfiles/${VIMPATCH}"
+else
+ die "Eek! I don't know how to interpret the version!"
+fi
+
+DESCRIPTION="Vi IMproved!"
+HOMEPAGE="http://www.vim.org/"
+
+SLOT="0"
+LICENSE="vim"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="=app-editors/vim-core-6.1
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+# It appears that the tclinterp stuff in Vim is broken right now (at
+# least on Linux... it works on BSD). When you --enable-tclinterp
+# flag, then the following command never returns:
+#
+# VIMINIT='let OS = system("uname -s")' vim
+#
+# Please don't re-enable the tclinterp flag without verifying first
+# that the above works. Thanks. (08 Sep 2001 agriffis)
+
+
+src_unpack() {
+ unpack ${A}
+ # Fixup a script to use awk instead of nawk
+ cd ${S}/runtime/tools
+ mv mve.awk mve.awk.old
+ ( read l; echo "#!/usr/bin/awk -f"; cat ) <mve.awk.old >mve.awk
+ # Another set of patch's borrowed from src rpm to fix syntax error's etc.
+ cd ${WORKDIR}
+ tar xvjf ${FILESDIR}/vimpatch.tar.bz2
+ cd $S
+ patch -p1 < ${WORKDIR}/vim-4.2-speed_t.patch || die
+ patch -p1 < ${WORKDIR}/vim-5.1-vimnotvi.patch || die
+ patch -p1 < ${WORKDIR}/vim-5.6a-paths.patch || die
+ patch -p1 < ${WORKDIR}/vim-6.0-fixkeys.patch || die
+ patch -p1 < ${WORKDIR}/vim-6.0-gcc31.patch || die
+ patch -p1 < ${WORKDIR}/vim-6.0-specsyntax.patch || die
+ patch -p1 < ${WORKDIR}/vim-6.0r-crv.patch || die
+
+ cd ${WORKDIR}
+ tar xvjf ${DISTDIR}/${VIMPATCH}
+ cd ${S}
+
+ if test -f ${WORKDIR}/6.1.080; then rm -f ${WORKDIR}/6.1.080; fi
+ if test -f ${WORKDIR}/6.1.084; then rm -f ${WORKDIR}/6.1.084; fi
+ # Apply any patches available for this version
+ local patches=`echo ${WORKDIR}/${PV}.[0-9][0-9][0-9]`
+ case "$patches" in
+ *\])
+ ;; # globbing didn't work; no patches available
+ *)
+ cd $S
+ for a in $patches; do
+ echo -n "Applying patch $a..."
+ patch -p0 < $a > /dev/null || die
+ echo "OK"
+ done
+ ;;
+ esac
+ patch -p0 < ${FILESDIR}/6.1_patches.80.84.diff || die
+}
+
+src_compile() {
+ local myconf
+ myconf="--without-x"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --with-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ # Default vimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}