summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-08-29 02:30:49 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-08-29 02:30:49 +0000
commita1c90b89d1e428c81a27a77474fb29e4915c24a1 (patch)
tree8a2b2ede649e5e417e7fe8c9ecf04adfb55961f0 /app-editors
parentPunt USE=diet. (diff)
downloadgentoo-2-a1c90b89d1e428c81a27a77474fb29e4915c24a1.tar.gz
gentoo-2-a1c90b89d1e428c81a27a77474fb29e4915c24a1.tar.bz2
gentoo-2-a1c90b89d1e428c81a27a77474fb29e4915c24a1.zip
Version bump.
(Portage version: 1.589-cvs)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog7
-rw-r--r--app-editors/scite/Manifest4
-rw-r--r--app-editors/scite/files/digest-scite-1.661
-rw-r--r--app-editors/scite/scite-1.66.ebuild71
4 files changed, 81 insertions, 2 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 310292fa69ca..a28dd1f5dd67 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.40 2005/08/04 17:15:11 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.41 2005/08/29 02:30:49 pythonhead Exp $
+
+*scite-1.66 (29 Aug 2005)
+
+ 29 Aug 2005; Rob Cakebread <pythonhead@gentoo.org> +scite-1.66.ebuild:
+ Version bump.
*scite-1.65 (04 Aug 2005)
*scite-1.64 (04 Aug 2005)
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 6ae6e203473b..27bf24c03ed2 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,13 +1,15 @@
-MD5 9e4f0517ed81c8dbc7a0a22709a3641a ChangeLog 6879
+MD5 2ceda6f09014a732adfbb52cd145fcb8 ChangeLog 6996
MD5 4eb1abff335478b86f5c65997e0148f2 metadata.xml 222
MD5 2927c01c99e22b737d685b95d80b4da2 scite-1.61.ebuild 1896
MD5 975972ac16269df2e1170664e5011288 scite-1.62.ebuild 1902
MD5 e3447388c372227f4a793db96b04826b scite-1.63.ebuild 1906
MD5 8b0e1f084ddb8ce6fd5d0b278a798cdb scite-1.64.ebuild 1906
MD5 0b37fe87a8ab98d22ff00a0d073ad375 scite-1.65.ebuild 1905
+MD5 fbab89155afd670a183114adbd06173e scite-1.66.ebuild 1859
MD5 c022b3ac9b612f257e304f7f90eb7f98 files/digest-scite-1.61 58
MD5 42ceb479aebfc9cd9818f0d6a0e39020 files/digest-scite-1.62 58
MD5 908c010850e453c17c24a7cefd399a63 files/digest-scite-1.63 58
MD5 6b68b046beca294c3e6c47715b936738 files/digest-scite-1.64 58
MD5 817229017073163998b48d9e8367d0ed files/digest-scite-1.65 58
+MD5 25a37792cee646cf2761847b44f68279 files/digest-scite-1.66 58
MD5 2561568c62ec3edc2b46be6638c80427 files/scite.desktop 169
diff --git a/app-editors/scite/files/digest-scite-1.66 b/app-editors/scite/files/digest-scite-1.66
new file mode 100644
index 000000000000..44e2691620a6
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.66
@@ -0,0 +1 @@
+MD5 62ce813c59e2d0206e875549dd300ee2 scite166.tgz 1259178
diff --git a/app-editors/scite/scite-1.66.ebuild b/app-editors/scite/scite-1.66.ebuild
new file mode 100644
index 000000000000..3734f9317c67
--- /dev/null
+++ b/app-editors/scite/scite-1.66.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.66.ebuild,v 1.1 2005/08/29 02:30:49 pythonhead Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="gtk2 lua"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ || die "error patching makefile"
+}
+
+src_compile() {
+ local makeopts
+ use gtk2 || makeopts="GTK1=1"
+ #use debug && makeopts="${makeopts} DEBUG=1"
+
+ make -C ../../scintilla/gtk ${makeopts} || die "prep make failed"
+ emake ${makeopts} || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}