summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-10-11 17:55:46 +0000
committerRémi Cardona <remi@gentoo.org>2007-10-11 17:55:46 +0000
commit9e5b3097427ac6ece8c9e92103ac5e9f6eea9d46 (patch)
tree67b41475c78dab94409f6fd76c327052c9a58561 /app-editors
parentAdded ifc as a possible fortran compiler, x11-libs/libXt as a dep, more clean... (diff)
downloadgentoo-2-9e5b3097427ac6ece8c9e92103ac5e9f6eea9d46.tar.gz
gentoo-2-9e5b3097427ac6ece8c9e92103ac5e9f6eea9d46.tar.bz2
gentoo-2-9e5b3097427ac6ece8c9e92103ac5e9f6eea9d46.zip
app-editors/gedit: forgot to add libattr patch (bug #195514)
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/ChangeLog6
-rw-r--r--app-editors/gedit/files/gedit-2.19.91-libattr.patch29
-rw-r--r--app-editors/gedit/gedit-2.20.0.ebuild4
3 files changed, 36 insertions, 3 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index ead90e895adc..7e566208a0dc 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.207 2007/10/10 21:32:52 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.208 2007/10/11 17:55:45 remi Exp $
+
+ 11 Oct 2007; Rémi Cardona <remi@gentoo.org>
+ +files/gedit-2.19.91-libattr.patch, gedit-2.20.0.ebuild:
+ forgot to add libattr patch (bug #195514)
*gedit-2.20.0 (10 Oct 2007)
diff --git a/app-editors/gedit/files/gedit-2.19.91-libattr.patch b/app-editors/gedit/files/gedit-2.19.91-libattr.patch
new file mode 100644
index 000000000000..b3f434d4cbd9
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.19.91-libattr.patch
@@ -0,0 +1,29 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN gedit-2.19.91.orig/configure.ac gedit-2.19.91/configure.ac
+--- gedit-2.19.91.orig/configure.ac 2007-08-28 03:44:13.000000000 -0400
++++ gedit-2.19.91/configure.ac 2007-09-13 16:04:46.000000000 -0400
+@@ -138,8 +138,16 @@ AC_SUBST(SPELL_PLUGIN_DIR)
+ dnl ================================================================
+ dnl libattr checks
+ dnl ================================================================
++AC_MSG_CHECKING([whether libattr support is requested])
++AC_ARG_ENABLE([attr],
++ AS_HELP_STRING([--enable-attr],[Enable libattr support]),
++ [enable_attr=$enableval have_attr=$enableval],
++ [enable_attr=autodetect have_attr=yes])
++AC_MSG_RESULT([$enable_attr])
+
+-AC_CHECK_LIB(attr, attr_copy_fd)
++if test "x$have_attr" != "xno"; then
++ AC_CHECK_LIB([attr], [attr_copy_fd], [], [have_attr=no])
++fi
+
+ dnl ================================================================
+ dnl Start of pkg-config checks
+@@ -367,6 +375,7 @@ Configuration:
+ Compiler: ${CC}
+ Python Plugins Support: $enable_python
+ Spell Plugin enabled: $enable_enchant
++ Libattr enabled: $have_attr
+ "
+
+ dnl uncomment this in developement releases
diff --git a/app-editors/gedit/gedit-2.20.0.ebuild b/app-editors/gedit/gedit-2.20.0.ebuild
index ca599f529972..e45ec5271d2c 100644
--- a/app-editors/gedit/gedit-2.20.0.ebuild
+++ b/app-editors/gedit/gedit-2.20.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.20.0.ebuild,v 1.1 2007/10/10 21:32:52 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.20.0.ebuild,v 1.2 2007/10/11 17:55:45 remi Exp $
inherit gnome2 eutils autotools
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="xattr doc python spell"
+IUSE="doc python spell xattr"
RDEPEND=">=gnome-base/gconf-2
xattr? ( sys-apps/attr )