summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-13 17:41:16 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-13 17:41:16 +0000
commit97f9421f4e61581d3d438e8785a6c1a772479643 (patch)
tree0279d240400f74a518d35fa37689e760d709f7b6 /app-editors
parentBased on 3.1.8 + genpatches-3.1-10 + grsecurity-2.2.2-3.1.8-201201111906 (diff)
downloadgentoo-2-97f9421f4e61581d3d438e8785a6c1a772479643.tar.gz
gentoo-2-97f9421f4e61581d3d438e8785a6c1a772479643.tar.bz2
gentoo-2-97f9421f4e61581d3d438e8785a6c1a772479643.zip
Add missing python cairo deps; modernize py-compile idiom.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/ChangeLog8
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild11
2 files changed, 13 insertions, 6 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 0f7abe23a9ef..3b5dd970d8d6 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit-plugins
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.21 2011/11/03 05:01:43 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.22 2012/01/13 17:41:16 tetromino Exp $
+
+ 13 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gedit-plugins-3.2.1-r1.ebuild:
+ Add missing python cairo deps; modernize py-compile idiom.
*gedit-plugins-3.2.1-r1 (03 Nov 2011)
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild
index d7c7866b7e26..c0bf2af9b7fd 100644
--- a/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild,v 1.1 2011/11/03 05:01:43 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.2.1-r1.ebuild,v 1.2 2012/01/13 17:41:16 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -28,7 +28,10 @@ RDEPEND=">=app-editors/gedit-3.2.0[python?]
>=x11-libs/gtksourceview-3.0.0:3.0
python? (
>=app-editors/gedit-3.0.0[introspection]
- || ( dev-python/pygobject:2[introspection] dev-python/pygobject:3 )
+ dev-python/pycairo
+ || (
+ dev-python/pygobject:2[cairo,introspection]
+ dev-python/pygobject:3[cairo] )
>=x11-libs/gtk+-3.0.0:3[introspection]
>=x11-libs/gtksourceview-3.0.0:3.0[introspection]
x11-libs/pango[introspection]
@@ -77,7 +80,7 @@ src_prepare() {
# disable pyc compiling
for d in . build-aux ; do
- ln -sfn $(type -P true) "${d}/py-compile"
+ echo > "${d}/py-compile"
done
}