summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-12 17:41:06 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-12 17:41:06 +0000
commit8f27a29ddf1775b4126721f15b3ba7dfc65337e4 (patch)
tree04c9acab23a89ddf3795c23bb09f343779be86e5 /app-editors
parentebuild cleanups (diff)
downloadgentoo-2-8f27a29ddf1775b4126721f15b3ba7dfc65337e4.tar.gz
gentoo-2-8f27a29ddf1775b4126721f15b3ba7dfc65337e4.tar.bz2
gentoo-2-8f27a29ddf1775b4126721f15b3ba7dfc65337e4.zip
ebuild cleanups
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jext/ChangeLog5
-rw-r--r--app-editors/jext/Manifest4
-rw-r--r--app-editors/jext/files/digest-jext-3.2_pre31
-rw-r--r--app-editors/jext/jext-3.2_pre3.ebuild22
4 files changed, 16 insertions, 16 deletions
diff --git a/app-editors/jext/ChangeLog b/app-editors/jext/ChangeLog
index 2b038bd381a6..27369ac1a5bb 100644
--- a/app-editors/jext/ChangeLog
+++ b/app-editors/jext/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/jext
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.5 2004/07/30 11:58:41 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.6 2004/09/12 17:40:20 axxo Exp $
+
+ 12 Sep 2004; Thomas Matthijs <axxo@gentoo.org> jext-3.2_pre3.ebuild:
+ ebuild cleanups
30 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org> jext-3.2_pre3.ebuild:
Moved dev-java/jython to dev-java/jython-bin.
diff --git a/app-editors/jext/Manifest b/app-editors/jext/Manifest
index 3265ba789f9c..cc7686398ae3 100644
--- a/app-editors/jext/Manifest
+++ b/app-editors/jext/Manifest
@@ -1,5 +1,5 @@
-MD5 9b412935d4c217d86cf3d730c5184f6a jext-3.2_pre3.ebuild 1051
-MD5 818b864b46c4a79aeee7e984f25143d6 ChangeLog 785
+MD5 e4e12f57069a182f30450917a227782b jext-3.2_pre3.ebuild 1051
+MD5 ec4f95cf2271f941886e527e92ee71ae ChangeLog 873
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 ba19c214a7e8f8ccb21f74bc3b3b1626 files/jext-gentoo.sh 1351
MD5 88b56bf3784153591e9487638ded6dfe files/digest-jext-3.2_pre3 73
diff --git a/app-editors/jext/files/digest-jext-3.2_pre3 b/app-editors/jext/files/digest-jext-3.2_pre3
index 9f060a85e4b0..7c8fea73e61d 100644
--- a/app-editors/jext/files/digest-jext-3.2_pre3
+++ b/app-editors/jext/files/digest-jext-3.2_pre3
@@ -1,2 +1 @@
-MD5 7de789ffe602f37b6b978439b3b048d1 jext-3.2pre3.tar.gz 2555439
MD5 57c1482cda431e5d5d7338ddc6ca5724 jext-sources-3.2pre3.tar.gz 1004576
diff --git a/app-editors/jext/jext-3.2_pre3.ebuild b/app-editors/jext/jext-3.2_pre3.ebuild
index 6479e398bd74..26e00b112cf3 100644
--- a/app-editors/jext/jext-3.2_pre3.ebuild
+++ b/app-editors/jext/jext-3.2_pre3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.12 2004/09/04 15:11:03 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.13 2004/09/12 17:40:20 axxo Exp $
inherit java-pkg
@@ -9,8 +9,7 @@ IUSE="doc"
DESCRIPTION="A cool and fully featured editor in Java"
HOMEPAGE="http://www.jext.org/"
MY_PV="${PV/_}"
-SRC_URI="mirror://sourceforge/jext/${PN}-${MY_PV}.tar.gz
- mirror://sourceforge/jext/${PN}-sources-${MY_PV}.tar.gz"
+SRC_URI="mirror://sourceforge/jext/${PN}-sources-${MY_PV}.tar.gz"
LICENSE="GPL-2 | JPython"
SLOT="0"
KEYWORDS="~x86 ~ppc sparc"
@@ -20,20 +19,19 @@ DEPEND=">=virtual/jdk-1.3
>=dev-java/jython-2.1-r5"
RDEPEND=">=virtual/jre-1.3"
-S=${WORKDIR}/${PN}-${MY_PV}
+S=${WORKDIR}/${PN}-sources-${MY_PV}
src_compile() {
- cd ${WORKDIR}/jext-sources-3.2pre3/src
- sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": build.xml > tmp.xml
- mv tmp.xml build.xml
- ant jar javadocs -quiet > /dev/null || die
+ cd ${S}/src
+ sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": -i build.xml
+ local antflags="jar"
+ use doc && antflags="${antflags} javadocs"
+ ant ${antflags} || die "compile failed"
}
src_install () {
- java-pkg_dojar ${WORKDIR}/jext-sources-3.2pre3/lib/*.jar
+ java-pkg_dojar lib/*.jar
exeinto /usr/bin
newexe ${FILESDIR}/jext-gentoo.sh jext
- if use doc; then
- dohtml -A .css .gif .jpg -r ${WORKDIR}/jext-sources-3.2pre3/docs/api
- fi
+ use doc && dohtml -A .css .gif .jpg -r docs/api
}