summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-01-04 10:35:22 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-01-04 10:35:22 +0000
commit8b5d0db1da7dc47e469eea116b6cd7db221663d7 (patch)
treeaa14561682a2da80fb49df5c9b98850d75009e93 /app-editors
parentold (diff)
downloadgentoo-2-8b5d0db1da7dc47e469eea116b6cd7db221663d7.tar.gz
gentoo-2-8b5d0db1da7dc47e469eea116b6cd7db221663d7.tar.bz2
gentoo-2-8b5d0db1da7dc47e469eea116b6cd7db221663d7.zip
EAPI=5 and l10n.eclass; remove old.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/tea-33.2.0.ebuild60
-rw-r--r--app-editors/tea/tea-33.3.0.ebuild20
3 files changed, 15 insertions, 73 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 6183d249de1f..21036e82b26c 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/tea
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.60 2012/09/18 08:31:17 pesa Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.61 2013/01/04 10:35:22 pesa Exp $
+
+ 04 Jan 2013; Davide Pesavento <pesa@gentoo.org> -tea-33.2.0.ebuild,
+ tea-33.3.0.ebuild:
+ EAPI=5 and l10n.eclass; remove old.
*tea-33.3.0 (18 Sep 2012)
diff --git a/app-editors/tea/tea-33.2.0.ebuild b/app-editors/tea/tea-33.2.0.ebuild
deleted file mode 100644
index 804026a6d569..000000000000
--- a/app-editors/tea/tea-33.2.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-33.2.0.ebuild,v 1.1 2012/08/02 23:04:55 pesa Exp $
-
-EAPI=4
-LANGS="de fr ru"
-
-inherit eutils qt4-r2
-
-DESCRIPTION="Small, lightweight Qt text editor"
-HOMEPAGE="http://tea-editor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
-IUSE="aspell hunspell"
-
-RDEPEND="
- sys-libs/zlib
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )
-"
-DEPEND="${RDEPEND}
- hunspell? ( virtual/pkgconfig )
-"
-
-DOCS="AUTHORS ChangeLog NEWS TODO"
-
-src_configure() {
- eqmake4 src.pro \
- PREFIX="${EPREFIX}/usr/bin" \
- USE_ASPELL=$(use aspell && echo true || echo false) \
- USE_HUNSPELL=$(use hunspell && echo true || echo false)
-}
-
-src_install() {
- qt4-r2_src_install
-
- newicon icons/tea_icon_v2.png ${PN}.png
- make_desktop_entry ${PN} Tea ${PN}
-
- # translations
- insinto /usr/share/qt4/translations
- local lang
- for lang in ${LANGS}; do
- if use linguas_${lang}; then
- doins translations/${PN}_${lang}.qm
- fi
- done
-
- # docs
- dohtml manuals/en.html
- if use linguas_ru; then
- dodoc NEWS-RU
- dohtml manuals/ru.html
- fi
-}
diff --git a/app-editors/tea/tea-33.3.0.ebuild b/app-editors/tea/tea-33.3.0.ebuild
index d26b4ae38419..9e2406c9ee3d 100644
--- a/app-editors/tea/tea-33.3.0.ebuild
+++ b/app-editors/tea/tea-33.3.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-33.3.0.ebuild,v 1.1 2012/09/18 08:31:17 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-33.3.0.ebuild,v 1.2 2013/01/04 10:35:22 pesa Exp $
-EAPI=4
-LANGS="de fr ru"
+EAPI=5
+PLOCALES="de fr ru"
-inherit eutils qt4-r2
+inherit eutils l10n qt4-r2
DESCRIPTION="Small, lightweight Qt text editor"
HOMEPAGE="http://tea-editor.sourceforge.net/"
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
hunspell? ( virtual/pkgconfig )
"
-DOCS="AUTHORS ChangeLog NEWS TODO"
+DOCS=(AUTHORS ChangeLog NEWS TODO)
src_configure() {
eqmake4 src.pro \
@@ -40,15 +40,13 @@ src_install() {
qt4-r2_src_install
newicon icons/tea_icon_v2.png ${PN}.png
- make_desktop_entry ${PN} Tea ${PN}
+ make_desktop_entry ${PN} 'Tea Editor'
# translations
insinto /usr/share/qt4/translations
local lang
- for lang in ${LANGS}; do
- if use linguas_${lang}; then
- doins translations/${PN}_${lang}.qm
- fi
+ for lang in $(l10n_get_locales); do
+ doins translations/${PN}_${lang}.qm
done
# docs