summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-03-03 11:13:35 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-03-03 11:13:35 +0000
commit88c06caaa241f0d51abf8db0ae3bcfd2eeddecef (patch)
tree26e5fe22daad2da729e8257367fed2d7e501a004 /app-editors
parentMark ~x86 wrt bug #302963 (required dependency) (diff)
downloadgentoo-2-88c06caaa241f0d51abf8db0ae3bcfd2eeddecef.tar.gz
gentoo-2-88c06caaa241f0d51abf8db0ae3bcfd2eeddecef.tar.bz2
gentoo-2-88c06caaa241f0d51abf8db0ae3bcfd2eeddecef.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.3.15.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index ce680fe5a8ff..550825eb8015 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.112 2010/01/31 16:08:07 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.113 2010/03/03 11:13:35 fauli Exp $
+
+*zile-2.3.15 (03 Mar 2010)
+
+ 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> +zile-2.3.15.ebuild:
+ version bump
*zile-2.3.14-r1 (31 Jan 2010)
diff --git a/app-editors/zile/zile-2.3.15.ebuild b/app-editors/zile/zile-2.3.15.ebuild
new file mode 100644
index 000000000000..17ca507be133
--- /dev/null
+++ b/app-editors/zile/zile-2.3.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.15.ebuild,v 1.1 2010/03/03 11:13:35 fauli Exp $
+
+EAPI=3
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="livecd test valgrind"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS || die
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [ -e "${EROOT}"/usr/bin/emacs ] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}