summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-10 01:30:58 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-10 01:30:58 +0000
commit85465b8d8c8ea346c987b3100241edc8d00d947a (patch)
treed586c4563458c44b49878b9af96f31820a1145bb /app-editors
parentDummy ebuild for pico. Fixes #3464 (diff)
downloadgentoo-2-85465b8d8c8ea346c987b3100241edc8d00d947a.tar.gz
gentoo-2-85465b8d8c8ea346c987b3100241edc8d00d947a.tar.bz2
gentoo-2-85465b8d8c8ea346c987b3100241edc8d00d947a.zip
New package. Fixes #3152
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/ChangeLog13
-rw-r--r--app-editors/jedit/files/digest-jedit-4.01
-rw-r--r--app-editors/jedit/jedit-4.0.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
new file mode 100644
index 000000000000..fc30eaceb954
--- /dev/null
+++ b/app-editors/jedit/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-editors/jedit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.1 2002/06/10 01:30:58 rphillips Exp $
+
+*jedit-4.0 (09 June 2002)
+
+ 09 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-editors/jedit/files/digest-jedit-4.0 b/app-editors/jedit/files/digest-jedit-4.0
new file mode 100644
index 000000000000..442e7e2b717d
--- /dev/null
+++ b/app-editors/jedit/files/digest-jedit-4.0
@@ -0,0 +1 @@
+MD5 2dd6cc7e842b117941b08cea520a9a59 jedit40source.tar.gz 1282934
diff --git a/app-editors/jedit/jedit-4.0.ebuild b/app-editors/jedit/jedit-4.0.ebuild
new file mode 100644
index 000000000000..5de60abc6d7f
--- /dev/null
+++ b/app-editors/jedit/jedit-4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2002 Maik Schreiber
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.ebuild,v 1.1 2002/06/10 01:30:58 rphillips Exp $
+
+S="${WORKDIR}/jEdit"
+DESCRIPTION="A programmer's editor written in Java"
+HOMEPAGE="http://www.jedit.org"
+LICENSE="GPL-2"
+DEPEND=">=dev-java/ant-1.4.1 >=dev-java/jikes-1.15"
+RDEPEND=">=virtual/jdk-1.3"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit40source.tar.gz"
+
+src_compile() {
+ ant -Dbuild.compiler=jikes || die
+}
+
+src_install () {
+ mkdir -m 755 -p ${D}/usr/jedit
+ mkdir -m 755 ${D}/usr/bin
+
+ cp -R jedit.jar jars macros modes properties startup ${D}/usr/jedit
+ chmod -R u+rw,ug-s,go+u,go-w \
+ ${D}/usr/jedit/jedit.jar \
+ ${D}/usr/jedit/jars \
+ ${D}/usr/jedit/macros \
+ ${D}/usr/jedit/modes \
+ ${D}/usr/jedit/properties \
+ ${D}/usr/jedit/startup
+
+ cat >${D}/usr/jedit/jedit.sh <<-EOF
+ #!/bin/bash
+
+ cd /usr/jedit
+ java -jar /usr/jedit/jedit.jar $@
+ EOF
+
+ chmod 755 ${D}/usr/jedit/jedit.sh
+
+ ln -s ../jedit/jedit.sh ${D}/usr/bin/jedit
+}