summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-30 07:49:23 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-30 07:49:23 +0000
commit7ec79c88cffdfba6af8e203fa9078d511084ccda (patch)
tree750536ab1d7caed2640c9efa2243666eaac9605b /app-editors
parentAdded vim 6.1 patches (diff)
downloadgentoo-2-7ec79c88cffdfba6af8e203fa9078d511084ccda.tar.gz
gentoo-2-7ec79c88cffdfba6af8e203fa9078d511084ccda.tar.bz2
gentoo-2-7ec79c88cffdfba6af8e203fa9078d511084ccda.zip
Added multibyte support to ebuild
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-6.1-r5.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 2d8cd143a5db..d3279bc6eb71 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.9 2002/04/30 07:21:36 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.10 2002/04/30 07:49:23 rphillips Exp $
*vim-6.1-r5 (30 Apr 2002)
30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r5.ebuild :
+ NLS will enable multibyte support now. I don't see a problem with
+ this...
+
+ 30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r5.ebuild :
+
Included patches for 6.1 in the files/ directory.
*vim-6.1-r4 (15 Apr 2002)
diff --git a/app-editors/vim/vim-6.1-r5.ebuild b/app-editors/vim/vim-6.1-r5.ebuild
index 21b53c13d6fb..8c6081213158 100644
--- a/app-editors/vim/vim-6.1-r5.ebuild
+++ b/app-editors/vim/vim-6.1-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Aron Griffis <agriffis@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r5.ebuild,v 1.3 2002/04/30 07:21:36 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r5.ebuild,v 1.4 2002/04/30 07:49:23 rphillips Exp $
# Please name the ebuild as follows. If this is followed, there
# should be no need to modify this ebuild when the Vim version is
@@ -103,11 +103,12 @@ src_unpack() {
src_compile() {
local myconf
- use nls || myconf="--disable-nls"
+ use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
use gpm || myconf="$myconf --disable-gpm"
use perl && myconf="$myconf --enable-perlinterp"
use python && myconf="$myconf --enable-pythoninterp"
use ruby && myconf="$myconf --enable-rubyinterp"
+
# tclinterp is BROKEN. See note above DEPEND=
# use tcltk && myconf="$myconf --enable-tclinterp"